Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1378801
| From | Pavel Machek <pavel@ucw.cz> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] fujitsu-laptop: Support radio LED |
| Date | 2016-04-14 14:50 +0200 |
| Message-ID | <rnOSB-1Gr-7@gated-at.bofh.it> (permalink) |
| References | <rdhOi-8i5-17@gated-at.bofh.it> <rmshs-In-11@gated-at.bofh.it> <rn5Ca-7oG-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi!
>
> Either your clock is really off or it took you 3 weeks to get this
> message out ;) Just letting you know.
Clock is off.
> > > +
> > > +static enum led_brightness radio_led_get(struct led_classdev *cdev);
> > > +static void radio_led_set(struct led_classdev *cdev,
> > > + enum led_brightness brightness);
> > > +
> > > +static struct led_classdev radio_led = {
> > > + .name = "fujitsu::radio_led",
> > > + .brightness_get = radio_led_get,
> > > + .brightness_set = radio_led_set
> > > +};
> >
> > Is the naming consistent with other drivers?
>
> I am not entirely clear what you are referring to. If it is the double
> colon, that seems to be the convention used throughout the
> platform-driver-x86 tree. If it is the LED's name ("radio_led"), I
> failed to find a similarly purposed LED in the platform-driver-x86 tree
> with a name I could reuse. I decided to use the _led suffix to
> differentiate this LED from the "lamps" already implemented by
> fujitsu-laptop.
I'd expected the led to be called "fujitsu::rfkill" but it looks that you
are first one in tree with something similar, so I guess you get to
pick the name.
It would be nice to have easily-available list of all the suffixes. We
have keyboard backlights, keyboard frontlights, LED flashes, ...
> > Should there be default trigger so that it works out of the box?
>
> I have covered this issue in the lengthy comment attached to this patch:
>
> > One last remark is that I think this LED would best be driven by an
> > inverted airplane mode LED trigger (as proposed by João Paulo Rechi
> > Vita). As the code for that trigger is not yet merged, I refrained from
> > setting the default_trigger field in struct led_classdev radio_led.
> > Perhaps it's a candidate for a follow-up patch in the future.
>
> I haven't found a way to make this work the intended way out of the box,
> not with the currently available set of LED triggers. That being said,
> I would be happy if someone proved me wrong.
Aha, ok.
Thanks,
Pavel
--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [PATCH] fujitsu-laptop: Support radio LED Pavel Machek <pavel@ucw.cz> - 2016-04-10 20:30 +0200
Re: [PATCH] fujitsu-laptop: Support radio LED Michał Kępień <kernel@kempniu.pl> - 2016-04-12 14:30 +0200
Re: [PATCH] fujitsu-laptop: Support radio LED Pavel Machek <pavel@ucw.cz> - 2016-04-14 14:50 +0200
csiph-web