Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1378501
| From | Hannes Reinecke <hare@suse.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 00/42] v5: separate operations from flags in the bio/request structs |
| Date | 2016-04-14 08:10 +0200 |
| Message-ID | <rnIDw-5In-5@gated-at.bofh.it> (permalink) |
| References | <rnyNP-6k4-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 04/13/2016 09:35 PM, mchristi@redhat.com wrote: > The following patches begin to cleanup the request->cmd_flags and > bio->bi_rw mess. We currently use cmd_flags to specify the operation, > attributes and state of the request. For bi_rw we use it for similar > info and also the priority but then also have another bi_flags field > for state. At some point, we abused them so much we just made cmd_flags > 64 bits, so we could add more. > > The following patches seperate the operation (read, write discard, > flush, etc) from cmd_flags/bi_rw. > > This patchset was made against linux-next from today April 13 > (git tag next-20160413). > > I put a git tree here: > https://github.com/mikechristie/linux-kernel.git > The patches are in the op branch. > A round of applause for you. For the entire series: Reviewed-by: Hannes Reinecke <hare@suse.com> Cheers, Hannes -- Dr. Hannes Reinecke Teamlead Storage & Networking hare@suse.de +49 911 74053 688 SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg GF: F. Imendörffer, J. Smithard, J. Guild, D. Upmanyu, G. Norton HRB 21284 (AG Nürnberg)
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 00/42] v5: separate operations from flags in the bio/request structs mchristi@redhat.com - 2016-04-13 21:40 +0200 [PATCH 23/42] md/raid: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-13 21:40 +0200 [PATCH 41/42] block: use QUEUE flags instead of flush_flags to test for flush support mchristi@redhat.com - 2016-04-13 21:40 +0200 [PATCH 42/42] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH mchristi@redhat.com - 2016-04-13 21:40 +0200 [PATCH 26/42] block: copy bio op to request op mchristi@redhat.com - 2016-04-13 21:40 +0200 [PATCH 40/42] block, drivers: add REQ_OP_FLUSH operation mchristi@redhat.com - 2016-04-13 21:40 +0200 [PATCH 36/42] ide cd: do not set REQ_WRITE on requests. mchristi@redhat.com - 2016-04-13 21:40 +0200 [PATCH 33/42] block: convert rq_data_dir helper to use REQ_OPs mchristi@redhat.com - 2016-04-13 21:50 +0200 [PATCH 32/42] block: convert is_sync helpers to use REQ_OPs. mchristi@redhat.com - 2016-04-13 21:50 +0200 [PATCH 25/42] target: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-13 21:50 +0200 [PATCH 30/42] blkg_rwstat: separate op from flags mchristi@redhat.com - 2016-04-13 21:50 +0200 [PATCH 28/42] block: prepare mq request creation to use REQ_OPs mchristi@redhat.com - 2016-04-13 21:50 +0200 [PATCH 34/42] drivers: set request op to REQ_OP mchristi@redhat.com - 2016-04-13 21:50 +0200 [PATCH 35/42] blktrace: get op from req->op/bio->bi_op mchristi@redhat.com - 2016-04-13 21:50 +0200 [PATCH 38/42] block, fs: remove old REQ definitions. mchristi@redhat.com - 2016-04-13 21:50 +0200 [PATCH 31/42] block: convert merge/insert code to check for REQ_OPs. mchristi@redhat.com - 2016-04-13 21:50 +0200 [PATCH 27/42] block: prepare request creation/destruction code to use REQ_OPs mchristi@redhat.com - 2016-04-13 21:50 +0200 [PATCH 37/42] block, fs, drivers: do use bi_rw/cmd_flags for REQ_OPs. mchristi@redhat.com - 2016-04-13 21:50 +0200 [PATCH 29/42] block: prepare elevator to use REQ_OPs. mchristi@redhat.com - 2016-04-13 21:50 +0200 [PATCH 12/42] gfs2: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-13 22:00 +0200 [PATCH 14/42] hfsplus: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-13 22:00 +0200 [PATCH 16/42] nilfs: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-13 22:00 +0200 [PATCH 15/42] mpage: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-13 22:00 +0200 [PATCH 22/42] drbd: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-13 22:00 +0200 [PATCH 07/42] btrfs: have submit_one_bio users setup bio bi_op mchristi@redhat.com - 2016-04-13 22:00 +0200 [PATCH 18/42] pm: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-13 22:00 +0200 [PATCH 20/42] dm: pass dm stats data dir instead of bi_rw mchristi@redhat.com - 2016-04-13 22:00 +0200 [PATCH 10/42] btrfs: use bio fields for op and flags mchristi@redhat.com - 2016-04-13 22:00 +0200 [PATCH 11/42] f2fs: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-13 22:00 +0200 [PATCH 17/42] ocfs2: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-13 22:00 +0200 [PATCH 09/42] btrfs: update __btrfs_map_block for bi_op transition mchristi@redhat.com - 2016-04-13 22:00 +0200 [PATCH 24/42] xen: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-13 22:00 +0200 [PATCH 19/42] dm: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-13 22:00 +0200 [PATCH 06/42] direct-io: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-13 22:10 +0200 [PATCH 02/42] block: add REQ_OP definitions and bi_op/op fields mchristi@redhat.com - 2016-04-13 22:10 +0200 [PATCH 05/42] fs: have ll_rw_block users pass in op and flags separately mchristi@redhat.com - 2016-04-13 22:10 +0200 [PATCH 04/42] fs: have submit_bh users pass in op and flags separately mchristi@redhat.com - 2016-04-13 22:10 +0200 Re: [PATCH 00/42] v5: separate operations from flags in the bio/request structs Hannes Reinecke <hare@suse.de> - 2016-04-14 08:10 +0200
csiph-web