Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1373867
| From | Yinghai Lu <yinghai@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v11 42/60] PCI: Skip required+optional if there is no optional |
| Date | 2016-04-08 02:30 +0200 |
| Message-ID | <rlstd-3DX-23@gated-at.bofh.it> (permalink) |
| References | <rlsjv-3zZ-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
If the bridge does not support hotplug and has no child with sriov support,
We will not have optional resources. We could get out early and
don't try required+optional allocation.
Also in the loop that update res with optional add info, skip resource
that add_size is 0.
Signed-off-by: Yinghai Lu <yinghai@kernel.org>
---
drivers/pci/setup-bus.c | 32 +++++++++++++++++++++++++++++---
1 file changed, 29 insertions(+), 3 deletions(-)
diff --git a/drivers/pci/setup-bus.c b/drivers/pci/setup-bus.c
index a4f53ec..373f76f 100644
--- a/drivers/pci/setup-bus.c
+++ b/drivers/pci/setup-bus.c
@@ -449,6 +449,24 @@ static bool pci_need_to_release(unsigned long mask, struct resource *res)
return false; /* should not get here */
}
+static bool has_addon(struct list_head *head,
+ struct list_head *realloc_head)
+{
+ int add_count = 0;
+ struct pci_dev_resource *dev_res, *tmp_res;
+
+ /* check if we have add really */
+ list_for_each_entry(dev_res, head, list) {
+ tmp_res = res_to_dev_res(realloc_head, dev_res->res);
+ if (!tmp_res || !tmp_res->add_size)
+ continue;
+
+ add_count++;
+ }
+
+ return add_count != 0;
+}
+
static bool save_resources(struct list_head *head,
struct list_head *save_head)
{
@@ -480,16 +498,24 @@ static bool __assign_resources_required_optional_sorted(struct list_head *head,
struct pci_dev_resource *save_res;
struct pci_dev_resource *dev_res, *tmp_res;
unsigned long fail_type;
- resource_size_t add_align;
+ resource_size_t add_align, add_size;
struct resource *res;
+ if (!has_addon(head, realloc_head))
+ return false;
+
if (!save_resources(head, &save_head))
return false;
/* Update res in head list with add_size in realloc_head list */
list_for_each_entry(dev_res, head, list) {
res = dev_res->res;
- res->end += get_res_add_size(realloc_head, res);
+ add_size = get_res_add_size(realloc_head, res);
+
+ if (!add_size)
+ continue;
+
+ res->end += add_size;
/*
* There are two kinds of additional resources in the list:
@@ -577,7 +603,7 @@ static void __assign_resources_sorted(struct list_head *head,
*/
/* Check required+optional add */
- if (realloc_head && !list_empty(realloc_head) &&
+ if (realloc_head &&
__assign_resources_required_optional_sorted(head, realloc_head))
return;
--
1.8.4.5
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v11 00/60] PCI: Resource allocation cleanup for v4.7 Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 22/60] PCI: Get new realloc size for bridge for last try Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 42/60] PCI: Skip required+optional if there is no optional Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 25/60] PCI: Reuse res_to_dev_res() in reassign_resources_sorted() Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 29/60] PCI: Don't add too much optional size for hotplug bridge MMIO Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 35/60] PCI: Simplify res reference using in __assign_resources_sorted() Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 32/60] PCI: Rename pdev_sort_resources() to pdev_assign_resources_prepare() Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 34/60] PCI: Add debug printout during releasing partial assigned resources Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 26/60] PCI: Use correct align for optional only resources during sorting Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 38/60] PCI: Check if resource is allocated before trying to assign one Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 31/60] PCI: Remove duplicated code for resource sorting Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 56/60] PCI: Add debug print out for min_align and alt_size Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 12/60] PCI: Check pref compatible bit for mem64 resource of PCIe device Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 58/60] PCI: Introduce resource_disabled() Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 24/60] PCI: Cleanup res_to_dev_res() printout Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 39/60] PCI: Separate out save_resources()/restore_resources() Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 49/60] PCI: Don't add too much io port for hotplug bridge with old size Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 54/60] resources: Make allocate_resource() return best fit resource Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 46/60] PCI: Fix size calculation with old_size on rescan path Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 48/60] PCI: Move ISA io port align out of calculate_iosize() Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 02/60] alpha/PCI: Only check iomem_is_exclusive() for IORESOURCE_MEM, not IORESOURCE_IO Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 41/60] PCI: Separate required+optional assigning to another function Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 33/60] PCI: Treat ROM resource as optional during realloc Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:30 +0200
[PATCH v11 28/60] PCI: Optimize bus align/size calculation for optional during sizing Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:40 +0200
[PATCH v11 04/60] sparc/PCI: Use correct offset for bus address to resource Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:40 +0200
[PATCH v11 23/60] PCI: Don't release sibling bridge resources during hotplug Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:40 +0200
[PATCH v11 05/60] sparc/PCI: Reserve legacy mmio after PCI mmio Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:40 +0200
[PATCH v11 53/60] PCI: Kill macro checking for bus io port sizing Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:40 +0200
[PATCH v11 03/60] PCI: Add pci_find_bus_resource() Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:40 +0200
[PATCH v11 11/60] OF/PCI: Add IORESOURCE_MEM_64 for 64-bit resource Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:40 +0200
[PATCH v11 06/60] sparc/PCI: Add IORESOURCE_MEM_64 for 64-bit resource in OF parsing Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:40 +0200
[PATCH v11 08/60] PCI: Kill wrong quirk about M7101 Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:40 +0200
[PATCH v11 14/60] PCI: Add has_mem64 for struct host_bridge Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:40 +0200
[PATCH v11 30/60] PCI: Reorder resources list for required/optional resources Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:40 +0200
[PATCH v11 44/60] PCI: Add alt_size ressource allocation support Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:40 +0200
Re: [PATCH v11 44/60] PCI: Add alt_size ressource allocation support Linus Torvalds <torvalds@linux-foundation.org> - 2016-04-08 03:00 +0200
Re: [PATCH v11 44/60] PCI: Add alt_size ressource allocation support Yinghai Lu <yinghai@kernel.org> - 2016-04-08 08:00 +0200
Re: [PATCH v11 44/60] PCI: Add alt_size ressource allocation support Benjamin Herrenschmidt <benh@kernel.crashing.org> - 2016-04-08 08:40 +0200
[PATCH v11 13/60] PCI: Only treat non-pref mmio64 as pref if all bridges have MEM_64 Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:40 +0200
[PATCH v11 19/60] PCI: Set resource to FIXED for LSI devices Yinghai Lu <yinghai@kernel.org> - 2016-04-08 02:40 +0200
Re: [PATCH v11 00/60] PCI: Resource allocation cleanup for v4.7 Linus Torvalds <torvalds@linux-foundation.org> - 2016-04-08 03:00 +0200
Re: [PATCH v11 00/60] PCI: Resource allocation cleanup for v4.7 Yinghai Lu <yinghai@kernel.org> - 2016-04-09 07:40 +0200
[PATCH v11 50/60] PCI: Unify calculate_size() for io port and MMIO Yinghai Lu <yinghai@kernel.org> - 2016-04-08 03:20 +0200
csiph-web