Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1374282

Re: [PATCH 1/2] kbuild: rename cmd_cc_i_c to cmd_cpp_i_c

From Arnaldo Carvalho de Melo <acme@redhat.com>
Newsgroups linux.kernel
Subject Re: [PATCH 1/2] kbuild: rename cmd_cc_i_c to cmd_cpp_i_c
Date 2016-04-08 17:10 +0200
Message-ID <rlGcO-5Mb-9@gated-at.bofh.it> (permalink)
References <rlulk-5fM-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Em Fri, Apr 08, 2016 at 11:24:47AM +0900, Masahiro Yamada escreveu:
> This command just preprocesses .c files into .i files, so cmd_cpp_i_c
> seems more suitable.

Thanks for doing it to the tools/build/ copy, looks sensible, I guess
this can go via the kbuild tree?

Acked-by: Arnaldo Carvalho de Melo <acme@redhat.com>

- Arnaldo
 
> Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
> ---
> 
>  scripts/Makefile.build     | 6 +++---
>  tools/build/Makefile.build | 8 ++++----
>  2 files changed, 7 insertions(+), 7 deletions(-)
> 
> diff --git a/scripts/Makefile.build b/scripts/Makefile.build
> index e1bc190..7e4df13 100644
> --- a/scripts/Makefile.build
> +++ b/scripts/Makefile.build
> @@ -152,11 +152,11 @@ cmd_cc_s_c       = $(CC) $(c_flags) $(DISABLE_LTO) -fverbose-asm -S -o $@ $<
>  $(obj)/%.s: $(src)/%.c FORCE
>  	$(call if_changed_dep,cc_s_c)
>  
> -quiet_cmd_cc_i_c = CPP $(quiet_modtag) $@
> -cmd_cc_i_c       = $(CPP) $(c_flags)   -o $@ $<
> +quiet_cmd_cpp_i_c = CPP $(quiet_modtag) $@
> +cmd_cpp_i_c       = $(CPP) $(c_flags) -o $@ $<
>  
>  $(obj)/%.i: $(src)/%.c FORCE
> -	$(call if_changed_dep,cc_i_c)
> +	$(call if_changed_dep,cpp_i_c)
>  
>  cmd_gensymtypes =                                                           \
>      $(CPP) -D__GENKSYMS__ $(c_flags) $< |                                   \
> diff --git a/tools/build/Makefile.build b/tools/build/Makefile.build
> index ee566e8..27f3583 100644
> --- a/tools/build/Makefile.build
> +++ b/tools/build/Makefile.build
> @@ -58,8 +58,8 @@ quiet_cmd_mkdir = MKDIR    $(dir $@)
>  quiet_cmd_cc_o_c = CC       $@
>        cmd_cc_o_c = $(CC) $(c_flags) -c -o $@ $<
>  
> -quiet_cmd_cc_i_c = CPP      $@
> -      cmd_cc_i_c = $(CC) $(c_flags) -E -o $@ $<
> +quiet_cmd_cpp_i_c = CPP      $@
> +      cmd_cpp_i_c = $(CC) $(c_flags) -E -o $@ $<
>  
>  quiet_cmd_cc_s_c = AS       $@
>        cmd_cc_s_c = $(CC) $(c_flags) -S -o $@ $<
> @@ -83,11 +83,11 @@ $(OUTPUT)%.o: %.S FORCE
>  
>  $(OUTPUT)%.i: %.c FORCE
>  	$(call rule_mkdir)
> -	$(call if_changed_dep,cc_i_c)
> +	$(call if_changed_dep,cpp_i_c)
>  
>  $(OUTPUT)%.s: %.S FORCE
>  	$(call rule_mkdir)
> -	$(call if_changed_dep,cc_i_c)
> +	$(call if_changed_dep,cpp_i_c)
>  
>  $(OUTPUT)%.s: %.c FORCE
>  	$(call rule_mkdir)
> -- 
> 1.9.1

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH 1/2] kbuild: rename cmd_cc_i_c to cmd_cpp_i_c Masahiro Yamada <yamada.masahiro@socionext.com> - 2016-04-08 04:30 +0200
  Re: [PATCH 1/2] kbuild: rename cmd_cc_i_c to cmd_cpp_i_c Arnaldo Carvalho de Melo <acme@redhat.com> - 2016-04-08 17:10 +0200

csiph-web