Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1372077
| From | Andrew Lunn <andrew@lunn.ch> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH net-next 1/3] net: dsa: make the STP state function return void |
| Date | 2016-04-06 01:50 +0200 |
| Message-ID | <rkITp-3fK-27@gated-at.bofh.it> (permalink) |
| References | <rkB5w-5V6-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
> -- port_stp_update: bridge layer function invoked when a given switch port STP > +- port_stp_state: bridge layer function invoked when a given switch port STP Hi Vivien port_stp_state_set might be a better name, to make it clear it is setting the state, not getting the current state, etc. Most of the other functions are _add, _prepare, _join, _leave, so _set would fit the pattern. Changing to a void makes sense. Andrew
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH net-next 1/3] net: dsa: make the STP state function return void Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2016-04-05 17:30 +0200
Re: [PATCH net-next 1/3] net: dsa: make the STP state function return void Andrew Lunn <andrew@lunn.ch> - 2016-04-06 01:50 +0200
Re: [PATCH net-next 1/3] net: dsa: make the STP state function return void Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2016-04-06 05:20 +0200
csiph-web