Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1370373

Re: [PATCH v3 01/16] mm: use put_page to free page instead of putback_lru_page

From Balbir Singh <bsingharora@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH v3 01/16] mm: use put_page to free page instead of putback_lru_page
Date 2016-04-04 08:00 +0200
Message-ID <rk5Im-6XA-9@gated-at.bofh.it> (permalink)
References <riiA1-1Vf-3@gated-at.bofh.it> <riiA1-1Vf-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw



On 30/03/16 18:12, Minchan Kim wrote:
> Procedure of page migration is as follows:
>
> First of all, it should isolate a page from LRU and try to
> migrate the page. If it is successful, it releases the page
> for freeing. Otherwise, it should put the page back to LRU
> list.
>
> For LRU pages, we have used putback_lru_page for both freeing
> and putback to LRU list. It's okay because put_page is aware of
> LRU list so if it releases last refcount of the page, it removes
> the page from LRU list. However, It makes unnecessary operations
> (e.g., lru_cache_add, pagevec and flags operations. It would be
> not significant but no worth to do) and harder to support new
> non-lru page migration because put_page isn't aware of non-lru
> page's data structure.
>
> To solve the problem, we can add new hook in put_page with
> PageMovable flags check but it can increase overhead in
> hot path and needs new locking scheme to stabilize the flag check
> with put_page.
>
> So, this patch cleans it up to divide two semantic(ie, put and putback).
> If migration is successful, use put_page instead of putback_lru_page and
> use putback_lru_page only on failure. That makes code more readable
> and doesn't add overhead in put_page.
So effectively when we return from unmap_and_move() the page is either
put_page or putback_lru_page() and the page is gone from under us.

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v3 01/16] mm: use put_page to free page instead of putback_lru_page Minchan Kim <minchan@kernel.org> - 2016-03-30 09:20 +0200
  Re: [PATCH v3 01/16] mm: use put_page to free page instead of  putback_lru_page Vlastimil Babka <vbabka@suse.cz> - 2016-04-01 15:00 +0200
    Re: [PATCH v3 01/16] mm: use put_page to free page instead of  putback_lru_page Minchan Kim <minchan@kernel.org> - 2016-04-04 03:40 +0200
      Re: [PATCH v3 01/16] mm: use put_page to free page instead of  putback_lru_page Naoya Horiguchi <n-horiguchi@ah.jp.nec.com> - 2016-04-04 06:50 +0200
        Re: [PATCH v3 01/16] mm: use put_page to free page instead of  putback_lru_page Vlastimil Babka <vbabka@suse.cz> - 2016-04-04 16:50 +0200
          Re: [PATCH v3 01/16] mm: use put_page to free page instead of  putback_lru_page Naoya Horiguchi <n-horiguchi@ah.jp.nec.com> - 2016-04-05 04:00 +0200
            Re: [PATCH v3 01/16] mm: use put_page to free page instead of  putback_lru_page Vlastimil Babka <vbabka@suse.cz> - 2016-04-05 10:30 +0200
              Re: [PATCH v3 01/16] mm: use put_page to free page instead of  putback_lru_page Naoya Horiguchi <n-horiguchi@ah.jp.nec.com> - 2016-04-06 03:00 +0200
                Re: [PATCH v3 01/16] mm: use put_page to free page instead of  putback_lru_page Vlastimil Babka <vbabka@suse.cz> - 2016-04-06 10:00 +0200
  Re: [PATCH v3 01/16] mm: use put_page to free page instead of  putback_lru_page Balbir Singh <bsingharora@gmail.com> - 2016-04-04 08:00 +0200
    Re: [PATCH v3 01/16] mm: use put_page to free page instead of  putback_lru_page Minchan Kim <minchan@kernel.org> - 2016-04-04 08:10 +0200
      Re: [PATCH v3 01/16] mm: use put_page to free page instead of  putback_lru_page Balbir Singh <bsingharora@gmail.com> - 2016-04-05 05:20 +0200

csiph-web