Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1369655
| From | Kent Overstreet <kent.overstreet@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/2] mm: Real pagecache iterators |
| Date | 2016-04-02 01:30 +0200 |
| Message-ID | <rjgFQ-3aL-5@gated-at.bofh.it> (permalink) |
| References | <riXa9-69N-3@gated-at.bofh.it> <riXa9-69N-7@gated-at.bofh.it> <riXa9-69N-5@gated-at.bofh.it> <rjgcO-2HK-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Fri, Apr 01, 2016 at 03:57:47PM -0700, Andrew Morton wrote: > On Thu, 31 Mar 2016 18:38:11 -0800 Kent Overstreet <kent.overstreet@gmail.com> wrote: > > > Introduce for_each_pagecache_page() and related macros, with the goal of > > replacing most/all uses of pagevec_lookup(). > > > > For the most part this shouldn't be a functional change. The one functional > > difference with the new macros is that they now take an @end parameter, so we're > > able to avoid grabbing pages in __find_get_pages() that we'll never use. > > > > This patch only does some of the conversions, the ones I was able to easily test > > myself - the conversions are mechanical but tricky enough they generally warrent > > testing. > > What is the reason for this change? I just got tired of code being hard to follow when I was trying to work on some pagecache invalidation stuff.
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [PATCH] mm: Refactor find_get_pages() & friends Andrew Morton <akpm@linux-foundation.org> - 2016-03-29 23:30 +0200
Re: [PATCH] mm: Refactor find_get_pages() & friends Kent Overstreet <kent.overstreet@gmail.com> - 2016-04-01 04:40 +0200
[PATCH 1/2] mm: Refactor find_get_pages() & friends Kent Overstreet <kent.overstreet@gmail.com> - 2016-04-01 04:40 +0200
[PATCH 2/2] mm: Real pagecache iterators Kent Overstreet <kent.overstreet@gmail.com> - 2016-04-01 04:40 +0200
Re: [PATCH 2/2] mm: Real pagecache iterators Andrew Morton <akpm@linux-foundation.org> - 2016-04-02 01:00 +0200
Re: [PATCH 2/2] mm: Real pagecache iterators Kent Overstreet <kent.overstreet@gmail.com> - 2016-04-02 01:30 +0200
csiph-web