Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1369552

Re: [PATCH v10 01/17] Xen: ACPI: Hide UART used by Xen

From "Rafael J. Wysocki" <rafael@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH v10 01/17] Xen: ACPI: Hide UART used by Xen
Date 2016-04-01 21:30 +0200
Message-ID <rjcVA-wc-11@gated-at.bofh.it> (permalink)
References <rj9uF-6rC-1@gated-at.bofh.it> <rj9Em-6vF-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, Apr 1, 2016 at 5:48 PM, Shannon Zhao <shannon.zhao@linaro.org> wrote:
> ACPI 6.0 introduces a new table STAO to list the devices which are used
> by Xen and can't be used by Dom0. On Xen virtual platforms, the physical
> UART is used by Xen. So here it hides UART from Dom0.
>
> CC: "Rafael J. Wysocki" <rjw@rjwysocki.net> (supporter:ACPI)
> CC: Len Brown <lenb@kernel.org> (supporter:ACPI)
> CC: linux-acpi@vger.kernel.org (open list:ACPI)
> Signed-off-by: Shannon Zhao <shannon.zhao@linaro.org>
> ---
>  drivers/acpi/scan.c | 71 +++++++++++++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 71 insertions(+)
>
> diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c
> index 5f28cf7..4d2d9eb 100644
> --- a/drivers/acpi/scan.c
> +++ b/drivers/acpi/scan.c
> @@ -45,6 +45,7 @@ static LIST_HEAD(acpi_scan_handlers_list);
>  DEFINE_MUTEX(acpi_device_lock);
>  LIST_HEAD(acpi_wakeup_device_list);
>  static DEFINE_MUTEX(acpi_hp_context_lock);

A comment here would be useful explaining that the below is an
exceptional thing an nothing like it is expected to be needed if
foreseeable future.

> +static u64 spcr_uart_addr;
>
>  struct acpi_dep_data {
>         struct list_head node;
> @@ -1453,6 +1454,44 @@ static int acpi_add_single_object(struct acpi_device **child,
>         return 0;
>  }
>
> +static acpi_status acpi_get_resource_memory(struct acpi_resource *ares,
> +                                           void *context)
> +{
> +       struct resource *res = context;
> +
> +       if (acpi_dev_resource_memory(ares, res))
> +               return AE_CTRL_TERMINATE;
> +
> +       return AE_OK;
> +}
> +
> +static bool acpi_device_should_be_hidden(acpi_handle handle)
> +{
> +       acpi_status status;
> +       struct resource res;
> +
> +       /* Check if it should ignore the UART device */
> +       if (!(spcr_uart_addr && acpi_has_method(handle, METHOD_NAME__CRS)))
> +               return false;
> +
> +       /*
> +        * The UART device described in SPCR table is assumed to have only one
> +        * memory resource present. So we only look for the first one here.
> +        */
> +       status = acpi_walk_resources(handle, METHOD_NAME__CRS,
> +                                    acpi_get_resource_memory, &res);
> +       if (ACPI_FAILURE(status))
> +               return false;
> +
> +       if (res.start == spcr_uart_addr) {

What about restructuring that a bit.

      if (ACPI_FAILURE(status) || res.start != spcr_uart_addr)
            return false;

> +               printk(KERN_INFO PREFIX "The UART device @%pa in SPCR table will be hidden\n",
> +                      &res.start);

And maybe use acpi_handle_info() for this message?

Thanks,
Rafael

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v10 00/17] Add ACPI support for Xen Dom0 on ARM64 Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 17:50 +0200
  [PATCH v10 01/17] Xen: ACPI: Hide UART used by Xen Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
    Re: [PATCH v10 01/17] Xen: ACPI: Hide UART used by Xen "Rafael J. Wysocki" <rafael@kernel.org> - 2016-04-01 21:30 +0200
  [PATCH v10 14/17] XEN: EFI: Move x86 specific codes to architecture directory Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
  [PATCH v10 03/17] Xen: xlate: Use page_to_xen_pfn instead of page_to_pfn Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
  [PATCH v10 16/17] FDT: Add a helper to get the subnode by given name Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
  [PATCH v10 09/17] xen/hvm/params: Add a new delivery type for event-channel in HVM_PARAM_CALLBACK_IRQ Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
  [PATCH v10 17/17] Xen: EFI: Parse DT parameters for Xen specific UEFI Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
  [PATCH v10 15/17] ARM64: XEN: Add a function to initialize Xen specific UEFI runtime services Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
  [PATCH v10 05/17] xen: memory : Add new XENMAPSPACE type XENMAPSPACE_dev_mmio Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
  [PATCH v10 13/17] ARM: Xen: Document UEFI support on Xen ARM virtual platforms Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
  [PATCH v10 06/17] Xen: ARM: Add support for mapping platform device mmio Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
    Re: [PATCH v10 06/17] Xen: ARM: Add support for mapping platform  device mmio Julien Grall <julien.grall@arm.com> - 2016-04-06 14:20 +0200
      Re: [PATCH v10 06/17] Xen: ARM: Add support for mapping platform  device mmio Shannon Zhao <zhaoshenglong@huawei.com> - 2016-04-07 03:40 +0200
        Re: [PATCH v10 06/17] Xen: ARM: Add support for mapping platform  device mmio Julien Grall <julien.grall@arm.com> - 2016-04-07 12:40 +0200
          Re: [PATCH v10 06/17] Xen: ARM: Add support for mapping platform  device mmio Shannon Zhao <zhaoshenglong@huawei.com> - 2016-04-07 13:30 +0200
  [PATCH v10 10/17] arm/xen: Get event-channel irq through HVM_PARAM when booting with ACPI Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
  [PATCH v10 11/17] ARM: XEN: Move xen_early_init() before efi_init() Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
  [PATCH v10 07/17] Xen: ARM: Add support for mapping AMBA device mmio Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
  [PATCH v10 04/17] arm/xen: Use xen_xlate_map_ballooned_pages to setup grant table Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
  [PATCH v10 02/17] xen/grant-table: Move xlated_setup_gnttab_pages to common place Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
    Re: [PATCH v10 02/17] xen/grant-table: Move xlated_setup_gnttab_pages  to common place Julien Grall <julien.grall@arm.com> - 2016-04-06 13:50 +0200
  [PATCH v10 08/17] Xen: public/hvm: sync changes of HVM_PARAM_CALLBACK_VIA ABI from Xen Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
  [PATCH v10 12/17] ARM64: ACPI: Check if it runs on Xen to enable or disable ACPI Shannon Zhao <shannon.zhao@linaro.org> - 2016-04-01 18:00 +0200
  Re: [PATCH v10 00/17] Add ACPI support for Xen Dom0 on ARM64 Julien Grall <julien.grall@arm.com> - 2016-04-06 13:40 +0200
    Re: [PATCH v10 00/17] Add ACPI support for Xen Dom0 on ARM64 Shannon Zhao <zhaoshenglong@huawei.com> - 2016-04-07 03:50 +0200
      Re: [PATCH v10 00/17] Add ACPI support for Xen Dom0 on ARM64 Julien Grall <julien.grall@arm.com> - 2016-04-07 12:40 +0200

csiph-web