Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1366959

Re: [PATCH v7 03/17] Xen: xlate: Use page_to_xen_pfn instead of page_to_pfn

From Shannon Zhao <zhaoshenglong@huawei.com>
Newsgroups linux.kernel
Subject Re: [PATCH v7 03/17] Xen: xlate: Use page_to_xen_pfn instead of page_to_pfn
Date 2016-03-30 09:40 +0200
Message-ID <riiTn-24i-3@gated-at.bofh.it> (permalink)
References <rgeKe-3Y1-7@gated-at.bofh.it> <rgeTU-42l-37@gated-at.bofh.it> <ri4GJ-pQ-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw



On 2016/3/30 0:28, Julien Grall wrote:
> Hi Shannon,
> 
> On 24/03/16 14:44, Shannon Zhao wrote:
>> Make xen_xlate_map_ballooned_pages work with 64K pages. In that case
>> Kernel pages are 64K in size but Xen pages remain 4K in size. Xen pfns
>> refer to 4K pages.
>>
>> Signed-off-by: Shannon Zhao <shannon.zhao@linaro.org>
>> Reviewed-by: Stefano Stabellini <stefano.stabellini@eu.citrix.com>
>> ---
>>   drivers/xen/xlate_mmu.c | 26 ++++++++++++++++----------
>>   1 file changed, 16 insertions(+), 10 deletions(-)
>>
>> diff --git a/drivers/xen/xlate_mmu.c b/drivers/xen/xlate_mmu.c
>> index 9692656..28f728b 100644
>> --- a/drivers/xen/xlate_mmu.c
>> +++ b/drivers/xen/xlate_mmu.c
>> @@ -207,9 +207,12 @@ int __init
>> xen_xlate_map_ballooned_pages(xen_pfn_t **gfns, void **virt,
>>       void *vaddr;
>>       int rc;
>>       unsigned int i;
>> +    unsigned long nr_pages;
>> +    xen_pfn_t xen_pfn = 0;
>>
>>       BUG_ON(nr_grant_frames == 0);
>> -    pages = kcalloc(nr_grant_frames, sizeof(pages[0]), GFP_KERNEL);
>> +    nr_pages = DIV_ROUND_UP(nr_grant_frames, XEN_PFN_PER_PAGE);
>> +    pages = kcalloc(nr_pages, sizeof(pages[0]), GFP_KERNEL);
>>       if (!pages)
>>           return -ENOMEM;
>>
>> @@ -218,22 +221,25 @@ int __init
>> xen_xlate_map_ballooned_pages(xen_pfn_t **gfns, void **virt,
>>           kfree(pages);
>>           return -ENOMEM;
>>       }
>> -    rc = alloc_xenballooned_pages(nr_grant_frames, pages);
>> +    rc = alloc_xenballooned_pages(nr_pages, pages);
>>       if (rc) {
>> -        pr_warn("%s Couldn't balloon alloc %ld pfns rc:%d\n", __func__,
>> -            nr_grant_frames, rc);
>> +        pr_warn("%s Couldn't balloon alloc %ld pages rc:%d\n", __func__,
>> +            nr_pages, rc);
>>           kfree(pages);
>>           kfree(pfns);
>>           return rc;
>>       }
>> -    for (i = 0; i < nr_grant_frames; i++)
>> -        pfns[i] = page_to_pfn(pages[i]);
>> +    for (i = 0; i < nr_grant_frames; i++) {
>> +        if ((i % XEN_PFN_PER_PAGE) == 0)
>> +            xen_pfn = page_to_xen_pfn(pages[i / XEN_PFN_PER_PAGE]);
>> +        pfns[i] = pfn_to_gfn(xen_pfn++);
>> +    }
> 
> Would it be possible to re-use xen_for_each_gfn? This will avoid
> open-coding the loop to break down the Linux page.
I don't think so. Using xen_acpi_guest_init will require factoring
"pfns[i] = pfn_to_gfn(xen_pfn++)" to a function with parameter pfns[i].
How can we pass pfns[i]?

Thanks,
-- 
Shannon

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v7 00/17] Add ACPI support for Xen Dom0 on ARM64 Shannon Zhao <shannon.zhao@linaro.org> - 2016-03-24 15:50 +0100
  [PATCH v7 08/17] Xen: public/hvm: sync changes of HVM_PARAM_CALLBACK_VIA ABI from Xen Shannon Zhao <shannon.zhao@linaro.org> - 2016-03-24 16:00 +0100
  [PATCH v7 06/17] Xen: ARM: Add support for mapping platform device mmio Shannon Zhao <shannon.zhao@linaro.org> - 2016-03-24 16:00 +0100
  [PATCH v7 02/17] xen/grant-table: Move xlated_setup_gnttab_pages to common place Shannon Zhao <shannon.zhao@linaro.org> - 2016-03-24 16:00 +0100
  [PATCH v7 10/17] arm/xen: Get event-channel irq through HVM_PARAM when booting with ACPI Shannon Zhao <shannon.zhao@linaro.org> - 2016-03-24 16:00 +0100
    Re: [PATCH v7 10/17] arm/xen: Get event-channel irq through HVM_PARAM  when booting with ACPI Julien Grall <julien.grall@arm.com> - 2016-03-29 18:40 +0200
      Re: [PATCH v7 10/17] arm/xen: Get event-channel irq through HVM_PARAM  when booting with ACPI Shannon Zhao <zhaoshenglong@huawei.com> - 2016-03-30 09:40 +0200
  [PATCH v7 05/17] xen: memory : Add new XENMAPSPACE type XENMAPSPACE_dev_mmio Shannon Zhao <shannon.zhao@linaro.org> - 2016-03-24 16:00 +0100
  [PATCH v7 03/17] Xen: xlate: Use page_to_xen_pfn instead of page_to_pfn Shannon Zhao <shannon.zhao@linaro.org> - 2016-03-24 16:00 +0100
    Re: [PATCH v7 03/17] Xen: xlate: Use page_to_xen_pfn instead of  page_to_pfn Julien Grall <julien.grall@arm.com> - 2016-03-29 18:30 +0200
      Re: [PATCH v7 03/17] Xen: xlate: Use page_to_xen_pfn instead of page_to_pfn Shannon Zhao <zhaoshenglong@huawei.com> - 2016-03-30 09:40 +0200
        Re: [PATCH v7 03/17] Xen: xlate: Use page_to_xen_pfn instead of  page_to_pfn Julien Grall <julien.grall@arm.com> - 2016-03-30 13:30 +0200
          Re: [PATCH v7 03/17] Xen: xlate: Use page_to_xen_pfn instead of  page_to_pfn Shannon Zhao <shannon.zhao@linaro.org> - 2016-03-30 14:50 +0200

csiph-web