Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1364606

Re: [PATCH 0/5] drivers/mtd: make several functions return bool

From Yaowei Bai <baiyaowei@cmss.chinamobile.com>
Newsgroups linux.kernel
Subject Re: [PATCH 0/5] drivers/mtd: make several functions return bool
Date 2016-03-25 09:50 +0100
Message-ID <rgvBn-7xe-11@gated-at.bofh.it> (permalink)
References <rgpZ0-3o9-1@gated-at.bofh.it> <rgq8G-3rj-3@gated-at.bofh.it> <rgtzA-6c1-9@gated-at.bofh.it> <rguOZ-70i-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, Mar 25, 2016 at 08:51:55AM +0100, Boris Brezillon wrote:
> Hi Yao,
> 
> On Fri, 25 Mar 2016 14:31:53 +0800
> Yaowei Bai <baiyaowei@cmss.chinamobile.com> wrote:
> 
> > On Fri, Mar 25, 2016 at 10:54:51AM +0800, Dongsheng Yang wrote:
> > > ccing: Brian and Richard
> > > 
> > > Hi Yao,
> > >     Is that really necessary? I am not sure how much benefit we can
> > > achieve from this change.
> > > Could you explain more?
> > 
> > Yes, according to these functions' name, a boolean return value is more
> > suitable and matchable.
> > 
> > Also personally think this change maybe benfit function's return value 
> > storage in the stack when called on certain architectures.
> 
> At least be honest, and say this is for your patchcount statistics :P.
> I'm fine taking the NAND related ones, but please, next time find
> something more useful to submit.

That's very nice of you, thanks.

> 
> Best Regards,
> 
> Boris
> 
> > 
> > > 
> > > Yang
> > > 
> > > On 03/25/2016 10:41 AM, Yaowei Bai wrote:
> > > >This series only make several funcitons return bool to improve
> > > >readability, no other funcitonal changes.
> > > >
> > > >Yaowei Bai (5):
> > > >   drivers/mtd: mtd_is_partition can be boolean
> > > >   drivers/mtd: cfi_interleave_supported can be boolean
> > > >   drivers/mtd: map_bankwidth_supported can be boolean
> > > >   drivers/mtd: mtd_nand_has_bch can be boolean
> > > >   drivers/mtd/nand: nand_opcode_8bits can be boolean
> > > >
> > > >  drivers/mtd/mtdpart.c          | 6 +++---
> > > >  include/linux/mtd/cfi.h        | 6 +++---
> > > >  include/linux/mtd/map.h        | 6 +++---
> > > >  include/linux/mtd/nand.h       | 6 +++---
> > > >  include/linux/mtd/nand_bch.h   | 4 ++--
> > > >  include/linux/mtd/partitions.h | 2 +-
> > > >  6 files changed, 15 insertions(+), 15 deletions(-)
> > > >
> > > 
> > 
> > 
> 
> 
> 
> -- 
> Boris Brezillon, Free Electrons
> Embedded Linux and Kernel engineering
> http://free-electrons.com

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/5] drivers/mtd: make several functions return bool Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2016-03-25 03:50 +0100
  [PATCH 1/5] drivers/mtd: mtd_is_partition can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2016-03-25 03:50 +0100
  [PATCH 5/5] drivers/mtd/nand: nand_opcode_8bits can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2016-03-25 03:50 +0100
  [PATCH 2/5] drivers/mtd: cfi_interleave_supported can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2016-03-25 03:50 +0100
  [PATCH 4/5] drivers/mtd: mtd_nand_has_bch can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2016-03-25 03:50 +0100
  [PATCH 3/5] drivers/mtd: map_bankwidth_supported can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2016-03-25 03:50 +0100
  Re: [PATCH 0/5] drivers/mtd: make several functions return bool Dongsheng Yang <dongsheng.yang@easystack.cn> - 2016-03-25 04:00 +0100
    Re: [PATCH 0/5] drivers/mtd: make several functions return bool Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2016-03-25 07:40 +0100
      Re: [PATCH 0/5] drivers/mtd: make several functions return bool Boris Brezillon <boris.brezillon@free-electrons.com> - 2016-03-25 09:00 +0100
        Re: [PATCH 0/5] drivers/mtd: make several functions return bool Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2016-03-25 09:50 +0100
      Re: [PATCH 0/5] drivers/mtd: make several functions return bool Richard Weinberger <richard@nod.at> - 2016-03-25 09:00 +0100
        Re: [PATCH 0/5] drivers/mtd: make several functions return bool Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2016-03-25 09:50 +0100
        Re: [PATCH 0/5] drivers/mtd: make several functions return bool Boris Brezillon <boris.brezillon@free-electrons.com> - 2016-03-25 10:00 +0100
          Re: [PATCH 0/5] drivers/mtd: make several functions return bool Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2016-03-25 10:30 +0100

csiph-web