Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1355792

Re: [PATCH v6 08/11] tpm: Driver for supporting multiple emulated TPMs

From Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com>
Newsgroups linux.kernel
Subject Re: [PATCH v6 08/11] tpm: Driver for supporting multiple emulated TPMs
Date 2016-03-11 11:30 +0100
Message-ID <rbsuu-4D2-27@gated-at.bofh.it> (permalink)
References <raQpc-2UT-7@gated-at.bofh.it> <raQpc-2UT-9@gated-at.bofh.it> <rbbN0-1h9-19@gated-at.bofh.it> <rbcJ4-1SN-23@gated-at.bofh.it>
Organization Intel Finland Oy - BIC 0357606-4 - Westendinkatu 7, 02160 Espoo

Show all headers | View raw


On Thu, Mar 10, 2016 at 12:32:15PM -0500, Stefan Berger wrote:
> On 03/10/2016 11:39 AM, Jarkko Sakkinen wrote:
> >+/* above flags */
> >+#define VTPM_FLAG_TPM2           1  /* emulator is TPM 2 */
> >+
> >+/* all supported flags */
> >+#define VTPM_FLAGS_ALL  (VTPM_FLAG_TPM2)
> >+
> >+#define VTPM_TPM 0xa0

A better name would be VTPM_IOC_MAGIC. You should also update
Documentation/ioctl/ioctl-number.txt.

> >+
> >+#define VTPM_NEW_DEV         _IOW(VTPM_TPM, 0x00, struct vtpm_new_dev)
> >I'd rather use VTPM_IOC_NEW_DEV.
> 
> What about the name of the structure ? vtpm_ioc_new_dev?

If I look at other subsystems like drm the common practice is either
name the ioctl as VTPM_NEW_DEV_IOCTL or VTPM_IOC_NEW_DEV and not have
suffix or postfix in the parameter struct. I would just copy that
convention here.

>    Stefan

/Jarkko

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v6 08/11] tpm: Driver for supporting multiple emulated TPMs Stefan Berger <stefanb@linux.vnet.ibm.com> - 2016-03-09 18:50 +0100
  Re: [PATCH v6 08/11] tpm: Driver for supporting multiple emulated TPMs Andy Lutomirski <luto@amacapital.net> - 2016-03-09 19:10 +0100
    Re: [PATCH v6 08/11] tpm: Driver for supporting multiple emulated  TPMs Stefan Berger <stefanb@linux.vnet.ibm.com> - 2016-03-10 03:40 +0100
      Re: [PATCH v6 08/11] tpm: Driver for supporting multiple emulated TPMs Andy Lutomirski <luto@amacapital.net> - 2016-03-10 04:00 +0100
        Re: [PATCH v6 08/11] tpm: Driver for supporting multiple emulated  TPMs Stefan Berger <stefanb@linux.vnet.ibm.com> - 2016-03-10 18:40 +0100
  Re: [PATCH v6 08/11] tpm: Driver for supporting multiple emulated  TPMs Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com> - 2016-03-10 15:20 +0100
  Re: [PATCH v6 08/11] tpm: Driver for supporting multiple emulated  TPMs Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com> - 2016-03-10 17:40 +0100
    Re: [PATCH v6 08/11] tpm: Driver for supporting multiple emulated  TPMs Stefan Berger <stefanb@linux.vnet.ibm.com> - 2016-03-10 18:40 +0100
      Re: [PATCH v6 08/11] tpm: Driver for supporting multiple emulated  TPMs Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com> - 2016-03-11 11:00 +0100
    Re: [PATCH v6 08/11] tpm: Driver for supporting multiple emulated  TPMs Stefan Berger <stefanb@linux.vnet.ibm.com> - 2016-03-10 18:40 +0100
      Re: [PATCH v6 08/11] tpm: Driver for supporting multiple emulated  TPMs Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com> - 2016-03-11 11:30 +0100
    Re: [PATCH v6 08/11] tpm: Driver for supporting multiple emulated  TPMs Jason Gunthorpe <jgunthorpe@obsidianresearch.com> - 2016-03-10 23:20 +0100

csiph-web