Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1351675

Re: [PATCH] mm: remove __GFP_NOFAIL is deprecated comment

From Vlastimil Babka <vbabka@suse.cz>
Newsgroups linux.kernel
Subject Re: [PATCH] mm: remove __GFP_NOFAIL is deprecated comment
Date 2016-03-07 16:00 +0100
Message-ID <ra4NA-49R-27@gated-at.bofh.it> (permalink)
References <r61EC-2xk-9@gated-at.bofh.it> <r62qZ-37z-1@gated-at.bofh.it> <r64sQ-4uZ-21@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 02/25/2016 02:48 PM, Michal Hocko wrote:
> On Thu 25-02-16 13:36:11, Nikolay Borisov wrote:
> -		if (unlikely(gfp_flags & __GFP_NOFAIL)) {
> -			/*
> -			 * __GFP_NOFAIL is not to be used in new code.
> -			 *
> -			 * All __GFP_NOFAIL callers should be fixed so that they
> -			 * properly detect and handle allocation failures.
> -			 *
> -			 * We most definitely don't want callers attempting to
> -			 * allocate greater than order-1 page units with
> -			 * __GFP_NOFAIL.
> -			 */
> -			WARN_ON_ONCE(order > 1);
> -		}
> +		/*
> +		 * We most definitely don't want callers attempting to
> +		 * allocate greater than order-1 page units with __GFP_NOFAIL.
> +		 */
> +		WARN_ON_ONCE((gfp_flags & __GFP_NOFAIL) && (order > 1));
>   		spin_lock_irqsave(&zone->lock, flags);
>
>   		page = NULL;
>

Hmm, even the reduced text (and the WARN_ON in the first place) sounds 
IMHO discouraging enough to make people think that opencoding a loop 
around such allocations is a good workaround. Yeah, we have a 
better/more thorough explanation around the __GFP_NOFAIL definition, but 
the WARN_ON will point people here.

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

Re: [PATCH] mm: remove __GFP_NOFAIL is deprecated comment Vlastimil Babka <vbabka@suse.cz> - 2016-03-07 16:00 +0100

csiph-web