Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1351554

Re: [PATCH net-next 3/9] bpf: pre-allocate hash map elements

From Daniel Borkmann <daniel@iogearbox.net>
Newsgroups linux.kernel
Subject Re: [PATCH net-next 3/9] bpf: pre-allocate hash map elements
Date 2016-03-07 12:40 +0100
Message-ID <ra1G2-2fN-9@gated-at.bofh.it> (permalink)
References <r9SCK-4Di-11@gated-at.bofh.it> <r9SMr-4VR-25@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 03/07/2016 02:58 AM, Alexei Starovoitov wrote:
[...]
> ---
>   include/linux/bpf.h      |   1 +
>   include/uapi/linux/bpf.h |   3 +
>   kernel/bpf/hashtab.c     | 264 ++++++++++++++++++++++++++++++++++-------------
>   kernel/bpf/syscall.c     |   2 +-
>   4 files changed, 196 insertions(+), 74 deletions(-)

Shouldn't all other map types (like array) need something like this as well to
reserve this for their future flags?

   if (attr->map_flags)
     return ERR_PTR(-EINVAL);

> diff --git a/include/linux/bpf.h b/include/linux/bpf.h
> index 4b070827200d..c81efb10bbb5 100644
> --- a/include/linux/bpf.h
> +++ b/include/linux/bpf.h
> @@ -37,6 +37,7 @@ struct bpf_map {
>   	u32 key_size;
>   	u32 value_size;
>   	u32 max_entries;
> +	u32 map_flags;

Just naming this 'flags' doesn't work due to the anonymous struct inside that
union, right? :/

>   	u32 pages;
>   	struct user_struct *user;
>   	const struct bpf_map_ops *ops;
> diff --git a/include/uapi/linux/bpf.h b/include/uapi/linux/bpf.h
> index 6496f98d3d68..5eeb2ca9441e 100644
> --- a/include/uapi/linux/bpf.h
> +++ b/include/uapi/linux/bpf.h
> @@ -101,12 +101,15 @@ enum bpf_prog_type {
>   #define BPF_NOEXIST	1 /* create new element if it didn't exist */
>   #define BPF_EXIST	2 /* update existing element */
>
> +#define BPF_F_NO_PREALLOC	(1ULL << 0)

Nit: Should better be (1U << 0) as map_flags are of __u32.

>   union bpf_attr {
>   	struct { /* anonymous struct used by BPF_MAP_CREATE command */
>   		__u32	map_type;	/* one of enum bpf_map_type */
>   		__u32	key_size;	/* size of key in bytes */
>   		__u32	value_size;	/* size of value in bytes */
>   		__u32	max_entries;	/* max number of entries in a map */
> +		__u32	map_flags;	/* prealloc or not */
>   	};
>
>   	struct { /* anonymous struct used by BPF_MAP_*_ELEM commands */

Thanks,
Daniel

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH net-next 0/9] bpf: hash map pre-alloc Alexei Starovoitov <ast@fb.com> - 2016-03-07 03:00 +0100
  [PATCH net-next 1/9] bpf: prevent kprobe+bpf deadlocks Alexei Starovoitov <ast@fb.com> - 2016-03-07 03:00 +0100
    Re: [PATCH net-next 1/9] bpf: prevent kprobe+bpf deadlocks Daniel Borkmann <daniel@iogearbox.net> - 2016-03-07 11:10 +0100
  [PATCH net-next 7/9] samples/bpf: test both pre-alloc and normal maps Alexei Starovoitov <ast@fb.com> - 2016-03-07 03:00 +0100
  [PATCH net-next 6/9] samples/bpf: add map_flags to bpf loader Alexei Starovoitov <ast@fb.com> - 2016-03-07 03:10 +0100
  [PATCH net-next 2/9] bpf: introduce percpu_freelist Alexei Starovoitov <ast@fb.com> - 2016-03-07 03:10 +0100
    Re: [PATCH net-next 2/9] bpf: introduce percpu_freelist Daniel Borkmann <daniel@iogearbox.net> - 2016-03-07 11:40 +0100
      Re: [PATCH net-next 2/9] bpf: introduce percpu_freelist Alexei Starovoitov <ast@fb.com> - 2016-03-07 19:30 +0100
  [PATCH net-next 4/9] samples/bpf: make map creation more verbose Alexei Starovoitov <ast@fb.com> - 2016-03-07 03:10 +0100
  [PATCH net-next 9/9] samples/bpf: add map performance test Alexei Starovoitov <ast@fb.com> - 2016-03-07 03:10 +0100
  [PATCH net-next 5/9] samples/bpf: move ksym_search() into library Alexei Starovoitov <ast@fb.com> - 2016-03-07 03:10 +0100
  [PATCH net-next 8/9] samples/bpf: add bpf map stress test Alexei Starovoitov <ast@fb.com> - 2016-03-07 03:10 +0100
  [PATCH net-next 3/9] bpf: pre-allocate hash map elements Alexei Starovoitov <ast@fb.com> - 2016-03-07 03:10 +0100
    Re: [PATCH net-next 3/9] bpf: pre-allocate hash map elements Daniel Borkmann <daniel@iogearbox.net> - 2016-03-07 12:40 +0100
      Re: [PATCH net-next 3/9] bpf: pre-allocate hash map elements Alexei Starovoitov <ast@fb.com> - 2016-03-07 19:40 +0100

csiph-web