Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1450350
| From | Jason Cooper <jason@lakedaemon.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC patch 1/6] random: Simplify API for random address requests |
| Date | 2016-07-26 05:40 +0200 |
| Message-ID | <rZ1nP-5ex-1@gated-at.bofh.it> (permalink) |
| References | <rYSNA-7Vk-7@gated-at.bofh.it> <rZ0UN-53b-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
All,
On Tue, Jul 26, 2016 at 03:01:55AM +0000, Jason Cooper wrote:
> To date, all callers of randomize_range() have set the length to 0, and
> check for a zero return value. For the current callers, the only way
> to get zero returned is if end <= start. Since they are all adding a
> constant to the start address, this is unnecessary.
>
> We can remove a bunch of needless checks by simplifying the API to do
> just what everyone wants, return an address between [start, start +
> range].
>
> While we're here, s/get_random_int/get_random_long/. No current call
> site is adversely affected by get_random_int(), since all current range
> requests are < MAX_UINT. However, we should match caller expectations
> to avoid coming up short (ha!) in the future.
>
> Signed-off-by: Jason Cooper <jason@lakedaemon.net>
> ---
> drivers/char/random.c | 17 ++++-------------
> include/linux/random.h | 2 +-
> 2 files changed, 5 insertions(+), 14 deletions(-)
>
> diff --git a/drivers/char/random.c b/drivers/char/random.c
> index 0158d3bff7e5..1251cb2cbab2 100644
> --- a/drivers/char/random.c
> +++ b/drivers/char/random.c
> @@ -1822,22 +1822,13 @@ unsigned long get_random_long(void)
> EXPORT_SYMBOL(get_random_long);
>
> /*
> - * randomize_range() returns a start address such that
> - *
> - * [...... <range> .....]
> - * start end
> - *
> - * a <range> with size "len" starting at the return value is inside in the
> - * area defined by [start, end], but is otherwise randomized.
> + * randomize_addr() returns a page aligned address within [start, start +
> + * range]
> */
> unsigned long
> -randomize_range(unsigned long start, unsigned long end, unsigned long len)
> +randomize_addr(unsigned long start, unsigned long range)
> {
> - unsigned long range = end - len - start;
> -
> - if (end <= start + len)
> - return 0;
> - return PAGE_ALIGN(get_random_int() % range + start);
> + return PAGE_ALIGN(get_random_long() % range + start);
> }
bah! old patch file. This should have been:
if (range == 0)
return start;
else
return PAGE_ALIGN(get_random_long() % range + start);
sorry,
Jason.
>
> /* Interface for in-kernel drivers of true hardware RNGs.
> diff --git a/include/linux/random.h b/include/linux/random.h
> index e47e533742b5..1ad877a98186 100644
> --- a/include/linux/random.h
> +++ b/include/linux/random.h
> @@ -34,7 +34,7 @@ extern const struct file_operations random_fops, urandom_fops;
>
> unsigned int get_random_int(void);
> unsigned long get_random_long(void);
> -unsigned long randomize_range(unsigned long start, unsigned long end, unsigned long len);
> +unsigned long randomize_addr(unsigned long start, unsigned long range);
>
> u32 prandom_u32(void);
> void prandom_bytes(void *buf, size_t nbytes);
> --
> 2.9.2
>
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] randomize_range: use random long instead of int william.c.roberts@intel.com - 2016-07-25 20:30 +0200
Re: [PATCH] randomize_range: use random long instead of int Kees Cook <keescook@chromium.org> - 2016-07-25 21:00 +0200
Re: [PATCH] randomize_range: use random long instead of int Jason Cooper <jason@lakedaemon.net> - 2016-07-26 04:20 +0200
[RFC patch 6/6] unicore32: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-26 05:10 +0200
[RFC patch 4/6] arm64: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-26 05:10 +0200
[RFC patch 3/6] ARM: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-26 05:10 +0200
[RFC patch 2/6] x86: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-26 05:10 +0200
[RFC patch 5/6] tile: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-26 05:10 +0200
[RFC patch 1/6] random: Simplify API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-26 05:10 +0200
Re: [RFC patch 1/6] random: Simplify API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-26 05:40 +0200
Re: [RFC patch 1/6] random: Simplify API for random address requests Kees Cook <keescook@chromium.org> - 2016-07-26 06:50 +0200
Re: [RFC patch 1/6] random: Simplify API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-26 19:10 +0200
Re: [RFC patch 1/6] random: Simplify API for random address requests Kees Cook <keescook@chromium.org> - 2016-07-26 19:10 +0200
Re: [RFC patch 1/6] random: Simplify API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-28 21:10 +0200
RE: [RFC patch 1/6] random: Simplify API for random address requests "Roberts, William C" <william.c.roberts@intel.com> - 2016-07-26 19:40 +0200
Re: [RFC patch 1/6] random: Simplify API for random address requests Kees Cook <keescook@chromium.org> - 2016-07-26 06:50 +0200
Re: [RFC patch 1/6] random: Simplify API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-26 18:00 +0200
Re: [RFC patch 1/6] random: Simplify API for random address requests Kees Cook <keescook@chromium.org> - 2016-07-26 18:50 +0200
Re: [kernel-hardening] [RFC patch 1/6] random: Simplify API for random address requests Yann Droneaud <ydroneaud@opteya.com> - 2016-07-27 16:30 +0200
csiph-web