Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1448811

Re: [PATCH v7 2/2] PCI: Rockchip: Add Rockchip PCIe controller support

From Brian Norris <briannorris@chromium.org>
Newsgroups linux.kernel
Subject Re: [PATCH v7 2/2] PCI: Rockchip: Add Rockchip PCIe controller support
Date 2016-07-23 00:30 +0200
Message-ID <rXR7c-3iw-11@gated-at.bofh.it> (permalink)
References <rW4UV-7AY-3@gated-at.bofh.it> <rW4UV-7AY-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hi Shawn,

On Mon, Jul 18, 2016 at 08:42:13AM +0800, Shawn Lin wrote:
> This patch adds Rockchip PCIe controller support found
> on RK3399 Soc platform.
> 
> Signed-off-by: Shawn Lin <shawn.lin@rock-chips.com>
> 
> ---
> 
> Changes in v7:
> - make it as a build-in driver
> - improve gen1/2 training timeout checking
> - only clear known interrupt
> - fix INTx for 0-base index

Also:
  - Fix infinite loop in legacy interrupt handler

(not that the changelog is that critical to get exactly right)

> 
> Changes in v6:
> - use "depends on PCI_MSI_IRQ_DOMAIN" suggested by Arnd
> 
> Changes in v5:
> - handle multiple pending INTx at the same time
>   suggested by Marc
> 
> Changes in v4:
> - address the comments from Brain
> 
> Changes in v3:
> - remove header file
> - remove struct msi_controller and move most of variables
>   of rockchip_pcie_port to become the local ones.
> - allow legacy int even if enabling MSI
> - drop regulator set voltage operation suggested by Doug
> 
> Changes in v2:
> - remove phy related stuff and call phy API
> - add new head file and define lots of macro to make
>   the code more readable
> - remove lots msi related code suggested by Marc
> - add IO window address translation
> - init_port and parse_dt reconstruction suggested by Bharat
> - improve wr_own_conf suggested by Arnd
> - make pcie as an interrupt controller and fix wrong int handler
>   suggested by Marc
> - remove PCI_PROBE_ONLY suggested by Lorenzo
> 
>  drivers/pci/host/Kconfig         |   11 +
>  drivers/pci/host/Makefile        |    1 +
>  drivers/pci/host/pcie-rockchip.c | 1233 ++++++++++++++++++++++++++++++++++++++
>  3 files changed, 1245 insertions(+)
>  create mode 100644 drivers/pci/host/pcie-rockchip.c
> 
[...]

Looks better to me:

Reviewed-by: Brian Norris <briannorris@chromium.org>

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v7 1/2] Documentation: bindings: add dt doc for Rockchip PCIe controller Shawn Lin <shawn.lin@rock-chips.com> - 2016-07-18 02:50 +0200
  [PATCH v7 2/2] PCI: Rockchip: Add Rockchip PCIe controller support Shawn Lin <shawn.lin@rock-chips.com> - 2016-07-18 02:50 +0200
    Re: [PATCH v7 2/2] PCI: Rockchip: Add Rockchip PCIe controller  support Brian Norris <briannorris@chromium.org> - 2016-07-23 00:30 +0200
  Re: [PATCH v7 1/2] Documentation: bindings: add dt doc for Rockchip  PCIe controller Brian Norris <briannorris@chromium.org> - 2016-07-22 22:40 +0200

csiph-web