Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1446756
| From | David Rientjes <rientjes@google.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/8] mm, page_alloc: set alloc_flags only once in slowpath |
| Date | 2016-07-20 00:30 +0200 |
| Message-ID | <rWLGx-1oo-5@gated-at.bofh.it> (permalink) |
| References | <rWeUh-5vO-7@gated-at.bofh.it> <rWeUh-5vO-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, 18 Jul 2016, Vlastimil Babka wrote: > In __alloc_pages_slowpath(), alloc_flags doesn't change after it's initialized, > so move the initialization above the retry: label. Also make the comment above > the initialization more descriptive. > > The only exception in the alloc_flags being constant is ALLOC_NO_WATERMARKS, > which may change due to TIF_MEMDIE being set on the allocating thread. We can > fix this, and make the code simpler and a bit more effective at the same time, > by moving the part that determines ALLOC_NO_WATERMARKS from > gfp_to_alloc_flags() to gfp_pfmemalloc_allowed(). This means we don't have to > mask out ALLOC_NO_WATERMARKS in numerous places in __alloc_pages_slowpath() > anymore. The only two tests for the flag can instead call > gfp_pfmemalloc_allowed(). > > Signed-off-by: Vlastimil Babka <vbabka@suse.cz> Acked-by: David Rientjes <rientjes@google.com> Looks good, although maybe a new name for gfp_pfmemalloc_allowed() would be in order.
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/8] compaction-related cleanups v4 Vlastimil Babka <vbabka@suse.cz> - 2016-07-18 13:30 +0200
[PATCH 7/8] mm, compaction: introduce direct compaction priority Vlastimil Babka <vbabka@suse.cz> - 2016-07-18 13:30 +0200
[PATCH 4/8] mm, page_alloc: restructure direct compaction handling in slowpath Vlastimil Babka <vbabka@suse.cz> - 2016-07-18 13:30 +0200
Re: [PATCH 4/8] mm, page_alloc: restructure direct compaction handling in slowpath David Rientjes <rientjes@google.com> - 2016-07-20 01:00 +0200
Re: [PATCH 4/8] mm, page_alloc: restructure direct compaction handling in slowpath Vlastimil Babka <vbabka@suse.cz> - 2016-07-20 18:10 +0200
[PATCH 5/8] mm, page_alloc: make THP-specific decisions more generic Vlastimil Babka <vbabka@suse.cz> - 2016-07-18 13:30 +0200
Re: [PATCH 5/8] mm, page_alloc: make THP-specific decisions more generic David Rientjes <rientjes@google.com> - 2016-07-20 01:20 +0200
Re: [PATCH 5/8] mm, page_alloc: make THP-specific decisions more generic Vlastimil Babka <vbabka@suse.cz> - 2016-07-21 09:20 +0200
[PATCH 6/8] mm, thp: remove __GFP_NORETRY from khugepaged and madvised allocations Vlastimil Babka <vbabka@suse.cz> - 2016-07-18 13:30 +0200
[PATCH 1/8] mm, compaction: don't isolate PageWriteback pages in MIGRATE_SYNC_LIGHT mode Vlastimil Babka <vbabka@suse.cz> - 2016-07-18 13:30 +0200
Re: [PATCH 1/8] mm, compaction: don't isolate PageWriteback pages in MIGRATE_SYNC_LIGHT mode David Rientjes <rientjes@google.com> - 2016-07-20 00:30 +0200
[PATCH 2/8] mm, page_alloc: set alloc_flags only once in slowpath Vlastimil Babka <vbabka@suse.cz> - 2016-07-18 13:30 +0200
Re: [PATCH 2/8] mm, page_alloc: set alloc_flags only once in slowpath David Rientjes <rientjes@google.com> - 2016-07-20 00:30 +0200
Re: [PATCH 2/8] mm, page_alloc: set alloc_flags only once in slowpath Vlastimil Babka <vbabka@suse.cz> - 2016-07-21 09:10 +0200
Re: [PATCH 0/8] compaction-related cleanups v4 Michal Hocko <mhocko@kernel.org> - 2016-07-18 13:40 +0200
Re: [PATCH 0/8] compaction-related cleanups v4 Mel Gorman <mgorman@techsingularity.net> - 2016-07-18 17:50 +0200
csiph-web