Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1446666
| From | Andrey Smirnov <andrew.smirnov@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/2] mtd: nand: Get rid of needless 'goto' |
| Date | 2016-07-19 20:50 +0200 |
| Message-ID | <rWIfD-7yk-11@gated-at.bofh.it> (permalink) |
| References | <rWFrr-5Qf-3@gated-at.bofh.it> <rWFrr-5Qf-1@gated-at.bofh.it> <rWI5Y-7uZ-21@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, Jul 19, 2016 at 11:30 AM, Brian Norris
<computersforpeace@gmail.com> wrote:
> On Tue, Jul 19, 2016 at 08:41:44AM -0700, Andrey Smirnov wrote:
>> Using "goto" in that "switch" statement only makes it harder to follow
>> control flow and doesn't bring any advantages. Rewrite the code to avoid
>> using "goto".
>>
>> Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
>> ---
>> drivers/mtd/nand/nand_base.c | 13 +++++--------
>> 1 file changed, 5 insertions(+), 8 deletions(-)
>>
>> diff --git a/drivers/mtd/nand/nand_base.c b/drivers/mtd/nand/nand_base.c
>> index 57043a6..8fa5536 100644
>> --- a/drivers/mtd/nand/nand_base.c
>> +++ b/drivers/mtd/nand/nand_base.c
>> @@ -2139,18 +2139,15 @@ static int nand_read_oob(struct mtd_info *mtd, loff_t from,
>> case MTD_OPS_PLACE_OOB:
>> case MTD_OPS_AUTO_OOB:
>> case MTD_OPS_RAW:
>> + if (!ops->datbuf)
>> + ret = nand_do_read_oob(mtd, from, ops);
>> + else
>> + ret = nand_do_read_ops(mtd, from, ops);
>> break;
>> -
>> default:
>> - goto out;
>> + break;
>> }
>>
>> - if (!ops->datbuf)
>> - ret = nand_do_read_oob(mtd, from, ops);
>> - else
>> - ret = nand_do_read_ops(mtd, from, ops);
>> -
>> -out:
>> nand_release_device(mtd);
>> return ret;
>> }
>
> The default case is really just a catch-all error case. We don't
> actually even need the nand_get_device() call for that... can we just
> do this instead?
Sure, although, if you don't mind, I'd rather you used:
if (ops->mode != MTD_OPS_PLACE_OOB &&
ops->mode != MTD_OPS_AUTO_OOB &&
ops->mode != MTD_OPS_RAW)
return -ENOTSUPP;
instead of the switch statement, IMHO, this way it is more obvious
that this codepath is just arguments correctness checking.
Andrey
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 2/2] mtd: nand: Get rid of needless 'goto' Andrey Smirnov <andrew.smirnov@gmail.com> - 2016-07-19 17:50 +0200
Re: [PATCH 2/2] mtd: nand: Get rid of needless 'goto' Brian Norris <computersforpeace@gmail.com> - 2016-07-19 20:40 +0200
Re: [PATCH 2/2] mtd: nand: Get rid of needless 'goto' Andrey Smirnov <andrew.smirnov@gmail.com> - 2016-07-19 20:50 +0200
Re: [PATCH 2/2] mtd: nand: Get rid of needless 'goto' Boris Brezillon <boris.brezillon@free-electrons.com> - 2016-07-19 21:00 +0200
Re: [PATCH 2/2] mtd: nand: Get rid of needless 'goto' Brian Norris <computersforpeace@gmail.com> - 2016-07-19 21:50 +0200
csiph-web