Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1445166

Re: [PATCH 1/2] x86/dumpstack: Optimize save_stack_trace

From Byungchul Park <byungchul.park@lge.com>
Newsgroups linux.kernel
Subject Re: [PATCH 1/2] x86/dumpstack: Optimize save_stack_trace
Date 2016-07-18 04:40 +0200
Message-ID <rW6Dn-jV-5@gated-at.bofh.it> (permalink)
References <rR9iy-4q7-27@gated-at.bofh.it> <rSezv-5yn-9@gated-at.bofh.it> <rSATq-3mr-77@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, Jul 08, 2016 at 12:08:19PM +0200, Ingo Molnar wrote:
> 
> * Byungchul Park <byungchul.park@lge.com> wrote:
> 
> > On Mon, Jul 04, 2016 at 07:27:54PM +0900, Byungchul Park wrote:
> > > I suggested this patch on https://lkml.org/lkml/2016/6/20/22. However,
> > > I want to proceed saperately since it's somewhat independent from each
> > > other. Frankly speaking, I want this patchset to be accepted at first so
> > > that the crossfeature can use this optimized save_stack_trace_norm()
> > > which makes crossrelease work smoothly.
> > 
> > What do you think about this way to improve it?
> 
> I like both of your improvements, the speed up is impressive:
> 
>   [    2.327597] save_stack_trace() takes 87114 ns
>   ...
>   [    2.781694] save_stack_trace() takes 20044 ns
>   ...
>   [    3.103264] save_stack_trace takes 3821 (sched_lock)
> 
> Could you please also measure call graph recording (perf record -g), how much 
> faster does it get with your patches and what are our remaining performance hot 
> spots?

Of course, I will.

> 
> Could you please merge your patches to the latest -tip tree, because this commit I 
> merged earlier today:

Sure.

> 
>   81c2949f7fdc x86/dumpstack: Add show_stack_regs() and use it
> 
> conflicts with your patches. (I'll push this commit out later today.)
> 
> Also, could you please rename the _norm names to _fast or so, to signal that this 
> is a faster but less reliable method to get a stack dump? Nobody knows what 
> '_norm' means, but '_fast' is pretty self-explanatory.

It would be better.

Thank you,
Byungchul

> 
> Thanks,
> 
> 	Ingo

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

Re: [PATCH 1/2] x86/dumpstack: Optimize save_stack_trace Byungchul Park <byungchul.park@lge.com> - 2016-07-18 04:40 +0200

csiph-web