Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1444497

Re: [PATCH v2 4/6] [media] vivid: code refactor for color representation

From Hans Verkuil <hverkuil@xs4all.nl>
Newsgroups linux.kernel
Subject Re: [PATCH v2 4/6] [media] vivid: code refactor for color representation
Date 2016-07-15 20:20 +0200
Message-ID <rVfSp-1LH-13@gated-at.bofh.it> (permalink)
References <rVe0h-D2-3@gated-at.bofh.it> <rVe0i-D2-31@gated-at.bofh.it> <rVfz4-1pW-33@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 07/15/2016 07:58 PM, Hans Verkuil wrote:
> On 07/15/2016 06:13 PM, Ricardo Ribalda Delgado wrote:
>> Replace is_yuv with color_representation. Which can be used by HSV
>> formats.
>>
>> This change should ease the review of the following patches.
> 
> It's a bit of a mouthful. How about calling this color_enc and TPG_COLOR_ENC_?
> (i.e. color encoding).
> 
> I would also like to have a TPG_COLOR_ENC_LUMA for the greyscale formats.
> This patch is a good opportunity to add that.

Also note that docs-next is older than the master branch w.r.t. the tpg.
You're missing two is_yuv checks is docs-next that are present in the master.

Also:

>> +static const char *tpg_color_representation_str(enum tgp_color_representation
>> +						 color_representation)
>> +{
>> +	switch (color_representation) {
>> +

Drop empty line.

>> +	case TGP_COLOR_REPRESENTATION_YUV:
>> +		return "YCbCr";
>> +	case TGP_COLOR_REPRESENTATION_RGB:
>> +	default:
>> +		return "RGB";
>> +
>> +	}
>> +}

Regards,

	Hans

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 0/6] Add HSV format Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2016-07-15 18:20 +0200
  [PATCH v2 3/6] [media] Documentation: Add Ricardo Ribalda Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2016-07-15 18:20 +0200
  [PATCH v2 2/6] [media] Documentation: Add HSV format Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2016-07-15 18:20 +0200
    Re: [PATCH v2 2/6] [media] Documentation: Add HSV format Laurent Pinchart <laurent.pinchart@ideasonboard.com> - 2016-07-15 20:20 +0200
      Re: [PATCH v2 2/6] [media] Documentation: Add HSV format Hans Verkuil <hverkuil@xs4all.nl> - 2016-07-16 10:20 +0200
        Re: [PATCH v2 2/6] [media] Documentation: Add HSV format Laurent Pinchart <laurent.pinchart@ideasonboard.com> - 2016-07-16 14:40 +0200
          Re: [PATCH v2 2/6] [media] Documentation: Add HSV format Hans Verkuil <hverkuil@xs4all.nl> - 2016-07-16 16:00 +0200
            Re: [PATCH v2 2/6] [media] Documentation: Add HSV format Laurent Pinchart <laurent.pinchart@ideasonboard.com> - 2016-07-16 16:20 +0200
              Re: [PATCH v2 2/6] [media] Documentation: Add HSV format Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2016-07-16 16:40 +0200
                Re: [PATCH v2 2/6] [media] Documentation: Add HSV format Hans Verkuil <hverkuil@xs4all.nl> - 2016-07-16 17:30 +0200
                Re: [PATCH v2 2/6] [media] Documentation: Add HSV format Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2016-07-16 18:00 +0200
                Re: [PATCH v2 2/6] [media] Documentation: Add HSV format Hans Verkuil <hverkuil@xs4all.nl> - 2016-07-16 18:20 +0200
              Re: [PATCH v2 2/6] [media] Documentation: Add HSV format Hans Verkuil <hverkuil@xs4all.nl> - 2016-07-16 17:20 +0200
      Re: [PATCH v2 2/6] [media] Documentation: Add HSV format Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2016-07-16 10:30 +0200
  [PATCH v2 6/6] [media] vivid: Rename variable Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2016-07-15 18:20 +0200
  [PATCH v2 5/6] [media] vivid: Add support for HSV formats Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2016-07-15 18:20 +0200
    Re: [PATCH v2 5/6] [media] vivid: Add support for HSV formats Hans Verkuil <hverkuil@xs4all.nl> - 2016-07-15 20:30 +0200
  [PATCH v2 4/6] [media] vivid: code refactor for color representation Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> - 2016-07-15 18:20 +0200
    Re: [PATCH v2 4/6] [media] vivid: code refactor for color  representation Hans Verkuil <hverkuil@xs4all.nl> - 2016-07-15 20:00 +0200
      Re: [PATCH v2 4/6] [media] vivid: code refactor for color  representation Hans Verkuil <hverkuil@xs4all.nl> - 2016-07-15 20:20 +0200
    Re: [PATCH v2 4/6] [media] vivid: code refactor for color  representation Hans Verkuil <hverkuil@xs4all.nl> - 2016-07-15 20:30 +0200

csiph-web