Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1439034

Re: Fix issue with alternatives/paravirt patches

From Jessica Yu <jeyu@redhat.com>
Newsgroups linux.kernel
Subject Re: Fix issue with alternatives/paravirt patches
Date 2016-07-08 02:00 +0200
Message-ID <rSrn4-5jw-3@gated-at.bofh.it> (permalink)
References <rRKUO-3fr-9@gated-at.bofh.it> <rSjSy-vy-15@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


+++ Petr Mladek [07/07/16 17:56 +0200]:
>On Tue 2016-07-05 22:34:58, Jessica Yu wrote:
>> Hi,
>>
>> A few months ago, Chris Arges reported a bug involving alternatives/paravirt
>> patching that was discussed here [1] and here [2]. To briefly summarize the
>> bug, patch modules that contained .altinstructions or .parainstructions
>> sections would break because these alternative/paravirt patches would be
>> applied first by the module loader (see x86 module_finalize()), then
>> livepatch would later clobber these patches when applying per-object
>> relocations. This lead to crashes and unpredictable behavior.
>>
>> One conclusion we reached from our last discussion was that we will
>> need to introduce some arch-specific code to address this problem.
>> This patchset presents a possible fix for the bug by adding a new
>> arch-specific arch_klp_init_object_loaded() function that by default
>> does nothing but can be overridden by different arches.
>>
>> To fix this issue for x86, since we can access a patch module's Elf
>> sections through mod->klp_info, we can simply delay the calls to
>> apply_paravirt() and apply_alternatives() to arch_klp_init_object_loaded(),
>> which is called after relocations have been written for an object.
>> In addition, for patch modules, .parainstructions and .altinstructions are
>> prefixed by ".klp.arch.${objname}" so that the module loader ignores them
>> and livepatch can apply them manually.
>
>The solution looks correct to me. The fun will be how to generate
>the sections. If I get this correctly, it is not enough to rename
>the existing ones. Instead, we need to split .parainstructions
>and .altinstructions sections into per-object ones.

Hi Petr,

That is correct, this means .parainstructions and .altinstructions
will be split per-object and follow a similar naming scheme to the
existing .klp.rela.${objname} sections. Then, we can apply these
sections per-object with apply_alternatives() and apply_paravirt().

>I wonder if there is a plan for this. Especially I am interested
>into the patches created from sources ;-) I wonder if we could add
>a tag somewhere and improve the build infrastructure.

I currently have a working branch of the kpatch-build tools that
generates these sections. I'm hoping to get the code up in some shape
or form soon; I'll post an update when it's up.

Jessica

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/2] Fix issue with alternatives/paravirt patches Jessica Yu <jeyu@redhat.com> - 2016-07-06 04:40 +0200
  [PATCH 2/2] livepatch/x86: apply alternatives and paravirt patches after relocations Jessica Yu <jeyu@redhat.com> - 2016-07-06 04:40 +0200
    Re: [PATCH 2/2] livepatch/x86: apply alternatives and paravirt  patches after relocations Josh Poimboeuf <jpoimboe@redhat.com> - 2016-07-08 17:50 +0200
  [PATCH 1/2] livepatch: use arch_klp_init_object_loaded() to finish arch-specific tasks Jessica Yu <jeyu@redhat.com> - 2016-07-06 04:40 +0200
  Re: [PATCH 0/2] Fix issue with alternatives/paravirt patches Petr Mladek <pmladek@suse.com> - 2016-07-07 18:00 +0200
    Re: [PATCH 0/2] Fix issue with alternatives/paravirt patches Josh Poimboeuf <jpoimboe@redhat.com> - 2016-07-08 01:00 +0200
    Re: Fix issue with alternatives/paravirt patches Jessica Yu <jeyu@redhat.com> - 2016-07-08 02:00 +0200
  Re: [PATCH 0/2] Fix issue with alternatives/paravirt patches Christopher Arges <chris.j.arges@canonical.com> - 2016-07-08 07:30 +0200
    Re: Fix issue with alternatives/paravirt patches Jessica Yu <jeyu@redhat.com> - 2016-07-08 19:00 +0200

csiph-web