Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1439268

RE: [PATCH] Need proper type casting before assignment, Remove compilation Warning.

From David Laight <David.Laight@ACULAB.COM>
Newsgroups linux.kernel
Subject RE: [PATCH] Need proper type casting before assignment, Remove compilation Warning.
Date 2016-07-08 12:10 +0200
Message-ID <rSATt-3mr-183@gated-at.bofh.it> (permalink)
References <rSmnn-2ax-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Arvind Yadav
> Sent: 07 July 2016 19:38
> -Return type of 'qe_muram_alloc' is 'unsigned long', That Was trying to
> assigned in ucc_fast_tx_virtual_fifo_base_offset and
> ucc_fast_rx_virtual_fifo_base_offset. These variable are 'unsigned int'.
> So before assginment need a proper type casting.

Are you sure, seems to me that the type of one of the fields is wrong.
The casts you are adding do not aid readability at all.

> -Passing value in IS_ERR_VALUE() is wrong, as they pass an 'int'
> into a function that takes an 'unsigned long' argument.This happens
> to work because the type is sign-extended on 64-bit architectures
> before it gets converted into an unsigned type.
> 
> -Passing an 'unsigned short' or 'unsigned int'argument into
> IS_ERR_VALUE() is guaranteed to be broken, as are 8-bit integers
> and types that are wider than 'unsigned long'.

Signed 8 and 16 bit values will be sign extended to 'int' before being
used in any arithmetic operation.
Unsigned ones get zero extended to 'int'.

That probably means you shouldn't be using IS_ERR_VALUE().

	David

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH] Need proper type casting before assignment, Remove compilation Warning. Arvind Yadav <arvind.yadav.cs@gmail.com> - 2016-07-07 20:40 +0200
  RE: [PATCH] Need proper type casting before assignment, Remove  compilation Warning. David Laight <David.Laight@ACULAB.COM> - 2016-07-08 12:10 +0200
  Re: [PATCH] Need proper type casting before assignment, Remove  compilation Warning. David Miller <davem@davemloft.net> - 2016-07-10 00:10 +0200

csiph-web