Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1436919

Re: [RFC] mips: Add MXU context switching support

From "Maciej W. Rozycki" <macro@imgtec.com>
Newsgroups linux.kernel
Subject Re: [RFC] mips: Add MXU context switching support
Date 2016-07-05 13:00 +0200
Message-ID <rRwf8-1IO-7@gated-at.bofh.it> (permalink)
References <rNUJ3-5m3-1@gated-at.bofh.it> <rRkGZ-2Z3-15@gated-at.bofh.it> <rRvsK-1qm-39@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, 5 Jul 2016, PrasannaKumar Muralidharan wrote:

> >> +     asm volatile(".word     0x700803ee\n\t");
> >> +     tsk->thread.mxu.xr[15] = reg_val;
> >> +}
> >
> >  Not using an output operand with asms here?
> 
> I think the instruction saves the xr* register value to reg_val
> without need for output operand.

 It does, a classic `asm' is supposed to act as an optimisation barrier.  

 However since you've used an operand `asm' in `__restore_mxu' I think 
it would be good for consistency to use one here as well; it would make 
this piece of code a little bit more readable too, as you wouldn't have 
to guess that the `asm' writes to `reg_val' then.

 So I suggest that you convert `__save_mxu' to use an operand `asm' as 
well.

  Maciej

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[RFC] mips: Add MXU context switching support PrasannaKumar Muralidharan <prasannatsmkumar@gmail.com> - 2016-06-25 14:20 +0200
  Re: [RFC] mips: Add MXU context switching support PrasannaKumar Muralidharan <prasannatsmkumar@gmail.com> - 2016-07-03 15:20 +0200
  Re: [RFC] mips: Add MXU context switching support Florian Fainelli <f.fainelli@gmail.com> - 2016-07-04 23:50 +0200
    Re: [RFC] mips: Add MXU context switching support PrasannaKumar Muralidharan <prasannatsmkumar@gmail.com> - 2016-07-05 11:50 +0200
  Re: [RFC] mips: Add MXU context switching support "Maciej W. Rozycki" <macro@imgtec.com> - 2016-07-05 00:40 +0200
    Re: [RFC] mips: Add MXU context switching support PrasannaKumar Muralidharan <prasannatsmkumar@gmail.com> - 2016-07-05 12:10 +0200
      Re: [RFC] mips: Add MXU context switching support "Maciej W. Rozycki" <macro@imgtec.com> - 2016-07-05 13:00 +0200
  Re: [RFC] mips: Add MXU context switching support Paul Burton <paul.burton@imgtec.com> - 2016-07-05 11:40 +0200
    Re: [RFC] mips: Add MXU context switching support PrasannaKumar Muralidharan <prasannatsmkumar@gmail.com> - 2016-07-05 17:30 +0200
    Re: [RFC] mips: Add MXU context switching support Andy Lutomirski <luto@amacapital.net> - 2016-07-05 18:20 +0200

csiph-web