Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1437845
| From | Alexander Potapenko <glider@google.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v5] kasan/quarantine: fix bugs on qlist_move_cache() |
| Date | 2016-07-06 18:50 +0200 |
| Message-ID | <rRYbo-39I-27@gated-at.bofh.it> (permalink) |
| References | <rRJm1-1YR-11@gated-at.bofh.it> <rRYbo-39I-29@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Wed, Jul 6, 2016 at 9:40 AM, Andrey Ryabinin <aryabinin@virtuozzo.com> wrote:
>
>
> On 07/06/2016 03:52 AM, js1304@gmail.com wrote:
>> From: Joonsoo Kim <iamjoonsoo.kim@lge.com>
>>
>> There are two bugs on qlist_move_cache(). One is that qlist's tail
>> isn't set properly. curr->next can be NULL since it is singly linked
>> list and NULL value on tail is invalid if there is one item on qlist.
>> Another one is that if cache is matched, qlist_put() is called and
>> it will set curr->next to NULL. It would cause to stop the loop
>> prematurely.
>>
>> These problems come from complicated implementation so I'd like to
>> re-implement it completely. Implementation in this patch is really
>> simple. Iterate all qlist_nodes and put them to appropriate list.
Neat trick :)
>> Unfortunately, I got this bug sometime ago and lose oops message.
>> But, the bug looks trivial and no need to attach oops.
>>
>> v5: rename some variable for better readability
>> v4: fix cache size bug s/cache->size/obj_cache->size/
>> v3: fix build warning
>>
>> Reviewed-by: Dmitry Vyukov <dvyukov@google.com>
>> Signed-off-by: Joonsoo Kim <iamjoonsoo.kim@lge.com>
>
> Fixes: 55834c59098d ("mm: kasan: initial memory quarantine implementation")
> Acked-by: Andrey Ryabinin <aryabinin@virtuozzo.com>
>
Acked-by: Alexander Potapenko <glider@google.com>
--
Alexander Potapenko
Software Engineer
Google Germany GmbH
Erika-Mann-Straße, 33
80636 München
Geschäftsführer: Matthew Scott Sucherman, Paul Terence Manicle
Registergericht und -nummer: Hamburg, HRB 86891
Sitz der Gesellschaft: Hamburg
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v5] kasan/quarantine: fix bugs on qlist_move_cache() js1304@gmail.com - 2016-07-06 03:00 +0200 Re: [PATCH v5] kasan/quarantine: fix bugs on qlist_move_cache() Alexander Potapenko <glider@google.com> - 2016-07-06 18:50 +0200
csiph-web