Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1433858
| From | Juergen Gross <jgross@suse.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [Xen-devel] [PATCH] x86/xen: Use DIV_ROUND_UP |
| Date | 2016-06-29 17:40 +0200 |
| Message-ID | <rPpKO-5V4-11@gated-at.bofh.it> (permalink) |
| References | <rPphL-5KQ-15@gated-at.bofh.it> <rPpKO-5V4-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 29/06/16 17:34, Jan Beulich wrote:
>>>> On 29.06.16 at 17:00, <amitoj1606@gmail.com> wrote:
>> --- a/arch/x86/xen/enlighten.c
>> +++ b/arch/x86/xen/enlighten.c
>> @@ -591,7 +591,7 @@ static void xen_load_gdt(const struct desc_ptr *dtr)
>> {
>> unsigned long va = dtr->address;
>> unsigned int size = dtr->size + 1;
>> - unsigned pages = (size + PAGE_SIZE - 1) / PAGE_SIZE;
>> + unsigned pages = DIV_ROUND_UP(size, PAGE_SIZE);
>> unsigned long frames[pages];
>> int f;
>>
>> @@ -640,7 +640,7 @@ static void __init xen_load_gdt_boot(const struct desc_ptr *dtr)
>> {
>> unsigned long va = dtr->address;
>> unsigned int size = dtr->size + 1;
>> - unsigned pages = (size + PAGE_SIZE - 1) / PAGE_SIZE;
>> + unsigned pages = DIV_ROUND_UP(size, PAGE_SIZE);
>> unsigned long frames[pages];
>> int f;
>>
>
> Perhaps even more readable would be PFN_DOWN()?
Or PFN_UP() to be correct?
Juergen
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] x86/xen: Use DIV_ROUND_UP Amitoj Kaur Chawla <amitoj1606@gmail.com> - 2016-06-29 17:10 +0200 Re: [Xen-devel] [PATCH] x86/xen: Use DIV_ROUND_UP Juergen Gross <jgross@suse.com> - 2016-06-29 17:40 +0200 Re: [Xen-devel] [PATCH] x86/xen: Use DIV_ROUND_UP "Jan Beulich" <JBeulich@suse.com> - 2016-06-29 17:40 +0200 Re: [Xen-devel] [PATCH] x86/xen: Use DIV_ROUND_UP David Vrabel <david.vrabel@citrix.com> - 2016-06-29 17:50 +0200
csiph-web