Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1429905
| From | Taeung Song <taeung.dev@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v11 2/3] perf config: Reimplement perf_config() introducing new perf_config__init() and perf_config__finish() |
| Date | 2016-06-23 16:40 +0200 |
| Message-ID | <rNdXr-2Tn-21@gated-at.bofh.it> (permalink) |
| References | <rNcyl-1Zv-3@gated-at.bofh.it> <rNcyl-1Zv-25@gated-at.bofh.it> <rNd1n-2aV-3@gated-at.bofh.it> <rNdE5-2KN-17@gated-at.bofh.it> <rNdXr-2Tn-19@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 06/23/2016 11:30 PM, Arnaldo Carvalho de Melo wrote: > Em Thu, Jun 23, 2016 at 11:15:49PM +0900, Taeung Song escreveu: >> >> >> On 06/23/2016 10:38 PM, Arnaldo Carvalho de Melo wrote: >>> Em Thu, Jun 23, 2016 at 10:03:39PM +0900, Taeung Song escreveu: >>>> +/** >>>> + * perf_config_sections__for_each - iterate thru all the sections >>>> + * @list: list_head instance to iterate >>>> + * @section: struct perf_config_section iterator >>>> + */ >>>> +#define perf_config_sections__for_each(list, section) \ >>>> + list_for_each_entry(section, list, node) >>>> + >>> >>> I was almost applying this but then there is a little detail, which is >>> that it is a goal to make the tools/ code look as much as kernel code as >>> possible, to encourage kernel developers to contribute to the tools >>> codebase and also to expose userspace developers to kernel practices. >>> >>> With that said, please rename these for_each macros to for_each_entry, >>> i.e.: >>> >>> perf_config_sections__for_each_entry() >>> perf_config_items__for_each_entry() >>> >>> As for_each and for_each_entry both exist in the kernel and have well >>> know semantics that we want to keep. >>> >>> Probably there are cases in tools/ where we break this rule, I'll check >>> and fix. >>> >> >> Granted ! :) >> >> I sent v12 with above changes a moment ago. > > Thanks, I've just converted evlist__for_each* and strlist__for_each to > this format. > Okey :-D I also think it seems great. Thanks, Taeung
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v11 0/3] perf config: Reimplement perf_config() Taeung Song <treeze.taeung@gmail.com> - 2016-06-23 15:10 +0200
[PATCH v11 1/3] perf config: Bring declarations about config from util/cache.h to util/config.h Taeung Song <treeze.taeung@gmail.com> - 2016-06-23 15:10 +0200
[PATCH v11 3/3] perf config: Reimplement show_config() using config_set__for_each Taeung Song <treeze.taeung@gmail.com> - 2016-06-23 15:10 +0200
[PATCH v11 2/3] perf config: Reimplement perf_config() introducing new perf_config__init() and perf_config__finish() Taeung Song <treeze.taeung@gmail.com> - 2016-06-23 15:10 +0200
Re: [PATCH v11 2/3] perf config: Reimplement perf_config() introducing new perf_config__init() and perf_config__finish() Arnaldo Carvalho de Melo <acme@kernel.org> - 2016-06-23 15:40 +0200
Re: [PATCH v11 2/3] perf config: Reimplement perf_config() introducing new perf_config__init() and perf_config__finish() Taeung Song <treeze.taeung@gmail.com> - 2016-06-23 16:20 +0200
Re: [PATCH v11 2/3] perf config: Reimplement perf_config() introducing new perf_config__init() and perf_config__finish() Arnaldo Carvalho de Melo <acme@kernel.org> - 2016-06-23 16:40 +0200
Re: [PATCH v11 2/3] perf config: Reimplement perf_config() introducing new perf_config__init() and perf_config__finish() Taeung Song <taeung.dev@gmail.com> - 2016-06-23 16:40 +0200
csiph-web