Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1426582

[PATCH 0/2] staging: comedi: plx9080.h: a couple more changes

From Ian Abbott <abbotti@mev.co.uk>
Newsgroups linux.kernel
Subject [PATCH 0/2] staging: comedi: plx9080.h: a couple more changes
Date 2016-06-20 15:10 +0200
Message-ID <rM77I-d8-5@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


A couple more changes to "plx9080.h" for easier extraction of fields
from register values, and macro naming consistency.

1) staging: comedi: plx9080.h: define PLX_<REG>_TO_<FIELD>(r) macros
2) staging: comedi: plx9080.h: rename some macros for consistency

 drivers/staging/comedi/drivers/cb_pcidas64.c |  4 +-
 drivers/staging/comedi/drivers/gsc_hpdi.c    |  2 +-
 drivers/staging/comedi/drivers/plx9080.h     | 95 ++++++++++++++--------------
 3 files changed, 49 insertions(+), 52 deletions(-)

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH 0/2] staging: comedi: plx9080.h: a couple more changes Ian Abbott <abbotti@mev.co.uk> - 2016-06-20 15:10 +0200
  [PATCH 1/2] staging: comedi: plx9080.h: define PLX_<REG>_TO_<FIELD>(r) macros Ian Abbott <abbotti@mev.co.uk> - 2016-06-20 15:10 +0200
  [PATCH 2/2] staging: comedi: plx9080.h: rename some macros for consistency Ian Abbott <abbotti@mev.co.uk> - 2016-06-20 15:10 +0200

csiph-web