Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1425846

[PATCH v2 0/6] x86: Rewrite switch_to()

From Brian Gerst <brgerst@gmail.com>
Newsgroups linux.kernel
Subject [PATCH v2 0/6] x86: Rewrite switch_to()
Date 2016-06-18 23:00 +0200
Message-ID <rLvvr-F3-3@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


This patch set simplifies the switch_to() code, by moving the stack switch
code out of line into an asm stub before calling __switch_to().  This ends
up being more readable, and using the C calling convention instead of
clobbering all registers improves code generation.  It also allows newly
forked processes to construct a special stack frame to seamlessly flow
to ret_from_fork, instead of using a test and branch, or an unbalanced
call/ret.

Changes from v1:
- Added struct inactive_task_frame
- Added comments about kernel threads returning to userspace
- Cleaned up some incorrect uses of thread.sp

Brian Gerst (6):
      x86-32, kgdb: Don't use thread.ip in sleeping_thread_to_gdb_regs()
      x86-64, kgdb: clear GDB_PS on 64-bit
      x86: Add struct inactive_task_frame
      x86: Rewrite switch_to() code
      x86: Pass kernel thread parameters in fork_frame
      x86: Fix thread_saved_pc()

 arch/x86/entry/entry_32.S          |  68 +++++++++++++-----
 arch/x86/entry/entry_64.S          |  76 ++++++++++++++------
 arch/x86/include/asm/processor.h   |  13 +---
 arch/x86/include/asm/stacktrace.h  |   4 +-
 arch/x86/include/asm/switch_to.h   | 142 +++++++------------------------------
 arch/x86/include/asm/thread_info.h |   2 -
 arch/x86/kernel/asm-offsets.c      |   6 ++
 arch/x86/kernel/asm-offsets_32.c   |   5 ++
 arch/x86/kernel/asm-offsets_64.c   |   5 ++
 arch/x86/kernel/kgdb.c             |   8 +--
 arch/x86/kernel/process.c          |  13 +++-
 arch/x86/kernel/process_32.c       |  29 +++-----
 arch/x86/kernel/process_64.c       |  19 ++---
 arch/x86/kernel/smpboot.c          |   1 -
 14 files changed, 187 insertions(+), 204 deletions(-)

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH v2 0/6] x86: Rewrite switch_to() Brian Gerst <brgerst@gmail.com> - 2016-06-18 23:00 +0200
  [PATCH v2 6/6] x86: Fix thread_saved_pc() Brian Gerst <brgerst@gmail.com> - 2016-06-18 23:00 +0200
    Re: [PATCH v2 6/6] x86: Fix thread_saved_pc() Josh Poimboeuf <jpoimboe@redhat.com> - 2016-06-20 18:10 +0200
      Re: [PATCH v2 6/6] x86: Fix thread_saved_pc() Brian Gerst <brgerst@gmail.com> - 2016-06-22 06:30 +0200
  [PATCH v2 2/6] x86-64, kgdb: clear GDB_PS on 64-bit Brian Gerst <brgerst@gmail.com> - 2016-06-18 23:00 +0200
  [PATCH v2 5/6] x86: Pass kernel thread parameters in fork_frame Brian Gerst <brgerst@gmail.com> - 2016-06-18 23:00 +0200
    Re: [PATCH v2 5/6] x86: Pass kernel thread parameters in fork_frame Andy Lutomirski <luto@amacapital.net> - 2016-06-19 23:30 +0200
      Re: [PATCH v2 5/6] x86: Pass kernel thread parameters in fork_frame Brian Gerst <brgerst@gmail.com> - 2016-06-20 00:10 +0200
    Re: [PATCH v2 5/6] x86: Pass kernel thread parameters in fork_frame Borislav Petkov <bp@suse.de> - 2016-06-20 16:00 +0200
      Re: [PATCH v2 5/6] x86: Pass kernel thread parameters in fork_frame Brian Gerst <brgerst@gmail.com> - 2016-06-20 17:20 +0200
        Re: [PATCH v2 5/6] x86: Pass kernel thread parameters in fork_frame Borislav Petkov <bp@alien8.de> - 2016-06-21 13:50 +0200
          Re: [PATCH v2 5/6] x86: Pass kernel thread parameters in fork_frame Brian Gerst <brgerst@gmail.com> - 2016-06-22 10:30 +0200
  Re: [PATCH v2 0/6] x86: Rewrite switch_to() Brian Gerst <brgerst@gmail.com> - 2016-06-20 00:10 +0200

csiph-web