Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1423726
| From | Quentin Armitage <quentin@armitage.org.uk> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v4 net] ipvs: fix bind to link-local mcast IPv6 address in backup |
| Date | 2016-06-16 09:10 +0200 |
| Message-ID | <rKzB7-5e9-3@gated-at.bofh.it> (permalink) |
| References | <rKzB7-5e9-5@gated-at.bofh.it> <rKyOJ-4I9-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
When using HEAD from
https://git.kernel.org/cgit/utils/kernel/ipvsadm/ipvsadm.git/,
the command:
ipvsadm --start-daemon backup --mcast-interface eth0.60 \
--mcast-group ff02::1:81
fails with the error message:
Argument list too long
whereas both:
ipvsadm --start-daemon master --mcast-interface eth0.60 \
--mcast-group ff02::1:81
and:
ipvsadm --start-daemon backup --mcast-interface eth0.60 \
--mcast-group 224.0.0.81
are successful.
The error message "Argument list too long" isn't helpful. The error occurs
because an IPv6 address is given in backup mode.
The error is in make_receive_sock() in net/netfilter/ipvs/ip_vs_sync.c,
since it fails to set the interface on the address or the socket before
calling inet6_bind() (via sock->ops->bind), where the test
'if (!sk->sk_bound_dev_if)' failed.
Setting sock->sk->sk_bound_dev_if on the socket before calling
inet6_bind() resolves the issue.
Fixes: d33288172e72 ("ipvs: add more mcast parameters for the sync daemon")
Signed-off-by: Quentin Armitage <quentin@armitage.org.uk>
---
net/netfilter/ipvs/ip_vs_sync.c | 6 ++++--
1 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/net/netfilter/ipvs/ip_vs_sync.c b/net/netfilter/ipvs/ip_vs_sync.c
index 803001a..1b07578 100644
--- a/net/netfilter/ipvs/ip_vs_sync.c
+++ b/net/netfilter/ipvs/ip_vs_sync.c
@@ -1545,7 +1545,8 @@ error:
/*
* Set up receiving multicast socket over UDP
*/
-static struct socket *make_receive_sock(struct netns_ipvs *ipvs, int id)
+static struct socket *make_receive_sock(struct netns_ipvs *ipvs, int id,
+ int ifindex)
{
/* multicast addr */
union ipvs_sockaddr mcast_addr;
@@ -1566,6 +1567,7 @@ static struct socket *make_receive_sock(struct netns_ipvs *ipvs, int id)
set_sock_size(sock->sk, 0, result);
get_mcast_sockaddr(&mcast_addr, &salen, &ipvs->bcfg, id);
+ sock->sk->sk_bound_dev_if = ifindex;
result = sock->ops->bind(sock, (struct sockaddr *)&mcast_addr, salen);
if (result < 0) {
pr_err("Error binding to the multicast addr\n");
@@ -1868,7 +1870,7 @@ int start_sync_thread(struct netns_ipvs *ipvs, struct ipvs_sync_daemon_cfg *c,
if (state == IP_VS_STATE_MASTER)
sock = make_send_sock(ipvs, id);
else
- sock = make_receive_sock(ipvs, id);
+ sock = make_receive_sock(ipvs, id, dev->ifindex);
if (IS_ERR(sock)) {
result = PTR_ERR(sock);
goto outtinfo;
--
1.7.7.6
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 0/5] ipvs: fix backup sync daemon with IPv6, and minor updates Quentin Armitage <quentin@armitage.org.uk> - 2016-06-14 16:30 +0200
[PATCH v2 2/5] ipvs: Stop calling __dev_get_by_name() repeatedly when starting sync daemon Quentin Armitage <quentin@armitage.org.uk> - 2016-06-14 16:30 +0200
[PATCH v2 1/5] ipvs: Enable setting IPv6 multicast address for ipvs sync daemon backup Quentin Armitage <quentin@armitage.org.uk> - 2016-06-14 16:30 +0200
Re: [PATCH v2 0/5] ipvs: fix backup sync daemon with IPv6, and minor updates Julian Anastasov <ja@ssi.bg> - 2016-06-15 07:30 +0200
Re: [PATCH v2 0/5] ipvs: fix backup sync daemon with IPv6, and minor updates Julian Anastasov <ja@ssi.bg> - 2016-06-15 22:00 +0200
[PATCH v3 4/4] ipvs: log additional sync daemon parameters Quentin Armitage <quentin@armitage.org.uk> - 2016-06-15 23:50 +0200
[PATCH v3 0/4] ipvs: fix backup sync daemon with IPv6, and minor updates Quentin Armitage <quentin@armitage.org.uk> - 2016-06-15 23:50 +0200
[PATCH v3 1/4] ipvs: Enable setting IPv6 multicast address for ipvs Quentin Armitage <quentin@armitage.org.uk> - 2016-06-15 23:50 +0200
[PATCH v3 3/4] ipvs: Don't check result < 0 after setting result = 0 Quentin Armitage <quentin@armitage.org.uk> - 2016-06-15 23:50 +0200
[PATCH v3 2/4] ipvs: Stop calling __dev_get_by_name() repeatedly when starting sync daemon Quentin Armitage <quentin@armitage.org.uk> - 2016-06-15 23:50 +0200
Re: [PATCH v3 0/4] ipvs: fix backup sync daemon with IPv6, and minor updates Julian Anastasov <ja@ssi.bg> - 2016-06-16 08:20 +0200
[PATCH v4 net] ipvs: fix bind to link-local mcast IPv6 address in backup Quentin Armitage <quentin@armitage.org.uk> - 2016-06-16 09:10 +0200
Re: [PATCH v4 net] ipvs: fix bind to link-local mcast IPv6 address in backup Julian Anastasov <ja@ssi.bg> - 2016-06-17 08:50 +0200
Re: [PATCH v4 net] ipvs: fix bind to link-local mcast IPv6 address in backup Simon Horman <horms@verge.net.au> - 2016-06-23 03:30 +0200
[PATCH net-next v4 1/3] ipvs: Stop calling __dev_get_by_name() repeatedly when starting sync daemon Quentin Armitage <quentin@armitage.org.uk> - 2016-06-16 09:10 +0200
[PATCH net-next v4 3/3] ipvs: log additional sync daemon parameters Quentin Armitage <quentin@armitage.org.uk> - 2016-06-16 09:10 +0200
[PATCH net-next v4 2/3] ipvs: Don't check result < 0 after setting result = 0 Quentin Armitage <quentin@armitage.org.uk> - 2016-06-16 09:10 +0200
csiph-web