Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1423793

[tip:perf/core] perf stdio: Do not pass hists in hist_entry__fprintf

From tip-bot for Jiri Olsa <tipbot@zytor.com>
Newsgroups linux.kernel
Subject [tip:perf/core] perf stdio: Do not pass hists in hist_entry__fprintf
Date 2016-06-16 10:40 +0200
Message-ID <rKB0d-5XD-13@gated-at.bofh.it> (permalink)
References <rK1g5-8wa-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Commit-ID:  8f1d1b4452ce71a231d1a22e6357285fb773c551
Gitweb:     http://git.kernel.org/tip/8f1d1b4452ce71a231d1a22e6357285fb773c551
Author:     Jiri Olsa <jolsa@kernel.org>
AuthorDate: Tue, 14 Jun 2016 20:19:17 +0200
Committer:  Arnaldo Carvalho de Melo <acme@redhat.com>
CommitDate: Wed, 15 Jun 2016 10:47:11 -0300

perf stdio: Do not pass hists in hist_entry__fprintf

There's no need, we have the hists pointer in struct hist_entry.

Signed-off-by: Jiri Olsa <jolsa@kernel.org>
Tested-by: Arnaldo Carvalho de Melo <acme@redhat.com>
Cc: David Ahern <dsahern@gmail.com>
Cc: Namhyung Kim <namhyung@kernel.org>
Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
Link: http://lkml.kernel.org/r/1465928361-2442-8-git-send-email-jolsa@kernel.org
Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
---
 tools/perf/ui/stdio/hist.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/tools/perf/ui/stdio/hist.c b/tools/perf/ui/stdio/hist.c
index 5d00783..150c4de 100644
--- a/tools/perf/ui/stdio/hist.c
+++ b/tools/perf/ui/stdio/hist.c
@@ -492,7 +492,6 @@ out:
 }
 
 static int hist_entry__fprintf(struct hist_entry *he, size_t size,
-			       struct hists *hists,
 			       char *bf, size_t bfsz, FILE *fp)
 {
 	int ret;
@@ -500,6 +499,7 @@ static int hist_entry__fprintf(struct hist_entry *he, size_t size,
 		.buf		= bf,
 		.size		= size,
 	};
+	struct hists *hists = he->hists;
 	u64 total_period = hists->stats.total_period;
 
 	if (size == 0 || size > bfsz)
@@ -755,7 +755,7 @@ size_t hists__fprintf(struct hists *hists, bool show_header, int max_rows,
 		if (percent < min_pcnt)
 			continue;
 
-		ret += hist_entry__fprintf(h, max_cols, hists, line, linesz, fp);
+		ret += hist_entry__fprintf(h, max_cols, line, linesz, fp);
 
 		if (max_rows && ++nr_rows >= max_rows)
 			break;

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 00/11] perf tools: Various fixes Jiri Olsa <jolsa@kernel.org> - 2016-06-14 20:20 +0200
  [PATCH 07/11] perf tools stdio: Do not pass hists in hist_entry__fprintf Jiri Olsa <jolsa@kernel.org> - 2016-06-14 20:30 +0200
    [tip:perf/core] perf stdio: Do not pass hists in  hist_entry__fprintf tip-bot for Jiri Olsa <tipbot@zytor.com> - 2016-06-16 10:40 +0200
  [PATCH 05/11] perf tools stdio: Separate hierarchy headers output Jiri Olsa <jolsa@kernel.org> - 2016-06-14 20:30 +0200
    [tip:perf/core] perf stdio: Separate hierarchy headers output tip-bot for Jiri Olsa <tipbot@zytor.com> - 2016-06-16 10:40 +0200
  [PATCH 06/11] perf tools stdio: Separate standard headers output Jiri Olsa <jolsa@kernel.org> - 2016-06-14 20:30 +0200
    [tip:perf/core] perf stdio: Separate standard headers output tip-bot for Jiri Olsa <tipbot@zytor.com> - 2016-06-16 10:40 +0200
  [PATCH 09/11] perf tools: Replace perf_evsel arg perf_hpp_fmt's header callback Jiri Olsa <jolsa@kernel.org> - 2016-06-14 20:30 +0200
    [tip:perf/core] perf hists: Replace perf_evsel arg perf_hpp_fmt's  header callback tip-bot for Jiri Olsa <tipbot@zytor.com> - 2016-06-16 10:40 +0200
  [PATCH 08/11] perf tools stdio: Add use_callchain parameter to hists__fprintf Jiri Olsa <jolsa@kernel.org> - 2016-06-14 20:30 +0200
    [tip:perf/core] perf stdio: Add use_callchain parameter to  hists__fprintf tip-bot for Jiri Olsa <tipbot@zytor.com> - 2016-06-16 10:40 +0200
  [PATCH 02/11] perf tools: Fix Data Object sort entry width index Jiri Olsa <jolsa@kernel.org> - 2016-06-14 20:30 +0200
    [tip:perf/core] perf tools: Fix Data Object sort entry width index tip-bot for Jiri Olsa <tipbot@zytor.com> - 2016-06-16 10:40 +0200
  [PATCH 11/11] perf tools: Rename __hists__add_entry to hists__add_entry Jiri Olsa <jolsa@kernel.org> - 2016-06-14 20:30 +0200
    [tip:perf/core] perf hists: Rename __hists__add_entry to  hists__add_entry tip-bot for Jiri Olsa <tipbot@zytor.com> - 2016-06-22 09:50 +0200

csiph-web