Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1422343

Re: [PATCH v2 net-next v2 05/12] net: dsa: mv88e6xxx: add switch register helpers

From Andrew Lunn <andrew@lunn.ch>
Newsgroups linux.kernel
Subject Re: [PATCH v2 net-next v2 05/12] net: dsa: mv88e6xxx: add switch register helpers
Date 2016-06-14 23:20 +0200
Message-ID <rK3UB-1OB-7@gated-at.bofh.it> (permalink)
References <rK1pL-88-3@gated-at.bofh.it> <rK1pN-88-57@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, Jun 14, 2016 at 02:31:46PM -0400, Vivien Didelot wrote:
> The mixed assignments, allocations and registrations in the probe code
> make it hard to follow the logic and figure out what is DSA or chip
> specific.
> 
> Extract the struct dsa_switch related code in a simple
> mv88e6xxx_register_switch helper function.
> 
> For symmetry in the code, add a mv88e6xxx_unregister_switch function.
> 
> Signed-off-by: Vivien Didelot <vivien.didelot@savoirfairelinux.com>

Reviewed-by: Andrew Lunn <andrew@lunn.ch>

    Andrew

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 net-next v2 00/12] net: dsa: mv88e6xxx: misc probe improvements Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2016-06-14 20:40 +0200
  [PATCH v2 net-next v2 05/12] net: dsa: mv88e6xxx: add switch register helpers Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2016-06-14 20:40 +0200
    Re: [PATCH v2 net-next v2 05/12] net: dsa: mv88e6xxx: add switch  register helpers Andrew Lunn <andrew@lunn.ch> - 2016-06-14 23:20 +0200
  [PATCH v2 net-next v2 01/12] net: dsa: mv88e6xxx: fix style issues Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2016-06-14 20:40 +0200
    Re: [PATCH v2 net-next v2 01/12] net: dsa: mv88e6xxx: fix style  issues Andrew Lunn <andrew@lunn.ch> - 2016-06-14 23:20 +0200

csiph-web