Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1419101

Re: [PATCH 3/3] mfd: hi655x-pmic: Add powerkey device to hi655x PMIC driver

From John Stultz <john.stultz@linaro.org>
Newsgroups linux.kernel
Subject Re: [PATCH 3/3] mfd: hi655x-pmic: Add powerkey device to hi655x PMIC driver
Date 2016-06-10 09:40 +0200
Message-ID <rIpcT-1FF-35@gated-at.bofh.it> (permalink)
References <rInkK-vX-9@gated-at.bofh.it> <rInkK-vX-15@gated-at.bofh.it> <rIpcT-1FF-37@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, Jun 10, 2016 at 12:32 AM, Lee Jones <lee.jones@linaro.org> wrote:
> On Thu, 09 Jun 2016, John Stultz wrote:
>
>> +static struct resource pwrkey_resources[] = {
>> +     {
>> +             .name   = "down",
>> +             .start  = 6,
>> +             .end    = 6,
>> +             .flags  = IORESOURCE_IRQ,
>> +     }, {
>> +             .name   = "up",
>> +             .start  = 5,
>> +             .end    = 5,
>> +             .flags  = IORESOURCE_IRQ,
>> +     }, {
>> +             .name   = "hold 4s",
>> +             .start  = 4,
>> +             .end    = 4,
>> +             .flags  = IORESOURCE_IRQ,
>> +     },
>> +};
>
> No idea what 4, 5 and 6 mean.  Please define them.

Fair enough. It already defines PWRON_D4SR_INT, PWRON_D20F_INT and
PWRON_D20R_INT, but those are unfortunately mask values. I'll add a
patch to rename those to be clearly mask values and generate them from
a proper define value as well.

>> +static const struct mfd_cell hi655x_pmic_devs[] = {
>> +     {
>> +             .name           = "hi655x-regulator",
>> +     },
>> +     {
>> +             .name           = "hi65xx-powerkey",
>> +             .num_resources  = ARRAY_SIZE(pwrkey_resources),
>> +             .resources      = &pwrkey_resources[0],
>> +     },
>> +};
>
> Nit: Place the -regulator entry at the bottom and turn it into a one
> liner:
>
>         { .name         = "hi655x-regulator", },

Sure.  Will do!

Thanks for the feedback!
-john

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 3/3] mfd: hi655x-pmic: Add powerkey device to hi655x PMIC driver John Stultz <john.stultz@linaro.org> - 2016-06-10 07:40 +0200
  Re: [PATCH 3/3] mfd: hi655x-pmic: Add powerkey device to hi655x PMIC driver John Stultz <john.stultz@linaro.org> - 2016-06-10 09:40 +0200
  Re: [PATCH 3/3] mfd: hi655x-pmic: Add powerkey device to hi655x PMIC  driver Lee Jones <lee.jones@linaro.org> - 2016-06-10 09:40 +0200

csiph-web