Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1413926
| From | Mike Galbraith <umgwanakikbuti@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [patch] mm/memcontrol.c::mem_cgroup_migrate() - replace another local_irq_disable() w. local_lock_irq() |
| Date | 2016-06-05 08:20 +0200 |
| Message-ID | <rGzzH-3cz-7@gated-at.bofh.it> (permalink) |
| References | <rFUPU-21R-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
v4.6 grew a local_irq_disable() in mm/memcontrol.c::mem_cgroup_migrate(). Convert it to use the existing local lock (event_lock) like the others. Signed-off-by: Mike Galbraith <umgwanakikbuti@gmail.com> --- mm/memcontrol.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) --- a/mm/memcontrol.c +++ b/mm/memcontrol.c @@ -5557,10 +5557,10 @@ void mem_cgroup_migrate(struct page *old commit_charge(newpage, memcg, false); - local_irq_disable(); + local_lock_irq(event_lock); mem_cgroup_charge_statistics(memcg, newpage, compound, nr_pages); memcg_check_events(memcg, newpage); - local_irq_enable(); + local_unlock_irq(event_lock); } DEFINE_STATIC_KEY_FALSE(memcg_sockets_enabled_key);
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[ANNOUNCE] 4.6.1-rt3 Sebastian Andrzej Siewior <bigeasy@linutronix.de> - 2016-06-03 12:50 +0200
[patch rfc] work-simple: Rename work-simple.[ch] to swork.[ch] for consistency Mike Galbraith <umgwanakikbuti@gmail.com> - 2016-06-05 08:20 +0200
Re: [patch rfc] work-simple: Rename work-simple.[ch] to swork.[ch] for consistency Sebastian Andrzej Siewior <bigeasy@linutronix.de> - 2016-06-06 11:00 +0200
[patch] mm/memcontrol.c::mem_cgroup_migrate() - replace another local_irq_disable() w. local_lock_irq() Mike Galbraith <umgwanakikbuti@gmail.com> - 2016-06-05 08:20 +0200
Re: [patch] mm/memcontrol.c::mem_cgroup_migrate() - replace another local_irq_disable() w. local_lock_irq() Sebastian Andrzej Siewior <bigeasy@linutronix.de> - 2016-06-06 11:00 +0200
[patch rfc] locking/rwsem: Add down_write_killable/killable_nested() Mike Galbraith <umgwanakikbuti@gmail.com> - 2016-06-07 06:20 +0200
Re: [patch rfc] locking/rwsem: Add down_write_killable/killable_nested() Sebastian Andrzej Siewior <bigeasy@linutronix.de> - 2016-06-09 15:10 +0200
csiph-web