Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1412383
| From | Dietmar Eggemann <dietmar.eggemann@arm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC PATCH 3/3] sched/fair: Change @running of __update_load_avg() to @update_util |
| Date | 2016-06-02 18:00 +0200 |
| Message-ID | <rFDcm-7Kh-15@gated-at.bofh.it> (permalink) |
| References | <rFk9H-4bk-29@gated-at.bofh.it> <rFkjo-4fq-19@gated-at.bofh.it> <rFkMp-4JV-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 01/06/16 21:11, Peter Zijlstra wrote: > On Wed, Jun 01, 2016 at 08:39:22PM +0100, Dietmar Eggemann wrote: >> The information whether a se/cfs_rq should get its load and >> utilization (se representing a task and root cfs_rq) or only its load >> (se representing a task group and cfs_rq owned by this se) updated can >> be passed into __update_load_avg() to avoid the additional if/else >> condition to set update_util. >> >> @running is changed to @update_util which now carries the information if >> the utilization of the se/cfs_rq should be updated and if the se/cfs_rq >> is running or not. >> >> Signed-off-by: Dietmar Eggemann <dietmar.eggemann@arm.com> >> --- >> kernel/sched/fair.c | 42 +++++++++++++++++++++--------------------- >> 1 file changed, 21 insertions(+), 21 deletions(-) >> >> diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c >> index 3ae8e79fb687..a1c13975cf56 100644 >> --- a/kernel/sched/fair.c >> +++ b/kernel/sched/fair.c >> @@ -2669,6 +2669,10 @@ static u32 __compute_runnable_contrib(u64 n) >> >> #define cap_scale(v, s) ((v)*(s) >> SCHED_CAPACITY_SHIFT) >> >> +#define upd_util_se(se, rng) ((entity_is_task(se) << 1) | (rng)) > > Just saying that on first reading that went: Random Number Generator, uh > what?! > > So maybe pick better names? Yeah, can do. What about? #define update_util_se(se, running) ((entity_is_task(se) << 1) | (running)) #define update_util_rq(cfs_rq) ((rq_is_root(cfs_rq) << 1) | !!(cfs_rq)->curr)
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[RFC PATCH 0/3] Aggregate task utilization only on root cfs_rq Dietmar Eggemann <dietmar.eggemann@arm.com> - 2016-06-01 21:40 +0200
[RFC PATCH 1/3] sched/fair: Aggregate task utilization only on root cfs_rq Dietmar Eggemann <dietmar.eggemann@arm.com> - 2016-06-01 21:40 +0200
Re: [RFC PATCH 1/3] sched/fair: Aggregate task utilization only on root cfs_rq Juri Lelli <juri.lelli@arm.com> - 2016-06-02 11:30 +0200
Re: [RFC PATCH 1/3] sched/fair: Aggregate task utilization only on root cfs_rq Dietmar Eggemann <dietmar.eggemann@arm.com> - 2016-06-02 18:00 +0200
Re: [RFC PATCH 1/3] sched/fair: Aggregate task utilization only on root cfs_rq Juri Lelli <juri.lelli@arm.com> - 2016-06-02 18:20 +0200
[RFC PATCH 2/3] sched/fair: Sync se with root cfs_rq Dietmar Eggemann <dietmar.eggemann@arm.com> - 2016-06-01 21:50 +0200
Re: [RFC PATCH 2/3] sched/fair: Sync se with root cfs_rq Leo Yan <leo.yan@linaro.org> - 2016-06-06 05:10 +0200
Re: [RFC PATCH 2/3] sched/fair: Sync se with root cfs_rq Dietmar Eggemann <dietmar.eggemann@arm.com> - 2016-06-06 10:50 +0200
Re: [RFC PATCH 2/3] sched/fair: Sync se with root cfs_rq Vincent Guittot <vincent.guittot@linaro.org> - 2016-06-06 14:20 +0200
[RFC PATCH 3/3] sched/fair: Change @running of __update_load_avg() to @update_util Dietmar Eggemann <dietmar.eggemann@arm.com> - 2016-06-01 21:50 +0200
Re: [RFC PATCH 3/3] sched/fair: Change @running of __update_load_avg() to @update_util Peter Zijlstra <peterz@infradead.org> - 2016-06-01 22:20 +0200
Re: [RFC PATCH 3/3] sched/fair: Change @running of __update_load_avg() to @update_util Dietmar Eggemann <dietmar.eggemann@arm.com> - 2016-06-02 18:00 +0200
Re: [RFC PATCH 3/3] sched/fair: Change @running of __update_load_avg() to @update_util Juri Lelli <juri.lelli@arm.com> - 2016-06-02 11:30 +0200
Re: [RFC PATCH 3/3] sched/fair: Change @running of __update_load_avg() to @update_util Dietmar Eggemann <dietmar.eggemann@arm.com> - 2016-06-02 19:30 +0200
Re: [RFC PATCH 3/3] sched/fair: Change @running of __update_load_avg() to @update_util Juri Lelli <juri.lelli@arm.com> - 2016-06-03 13:00 +0200
Re: [RFC PATCH 0/3] Aggregate task utilization only on root cfs_rq Peter Zijlstra <peterz@infradead.org> - 2016-06-01 22:20 +0200
Re: [RFC PATCH 0/3] Aggregate task utilization only on root cfs_rq Dietmar Eggemann <dietmar.eggemann@arm.com> - 2016-06-02 17:50 +0200
csiph-web