Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1408524
| Path | csiph.com!news.mixmin.net!news.unit0.net!news.panservice.it!diesel.cu.mi.it!bofh.it!news.nic.it!robomod |
|---|---|
| From | Guenter Roeck <linux@roeck-us.net> |
| Newsgroups | linux.kernel |
| Subject | Re: pxa_defconfig runtime failures due to 'ARM: pxa: activate pinctrl for device-tree machines' |
| Date | Sat, 28 May 2016 23:20:01 +0200 |
| Message-ID | <rDTOh-5AD-3@gated-at.bofh.it> (permalink) |
| References | <rDwyn-82g-39@gated-at.bofh.it> <rDHN7-6yQ-15@gated-at.bofh.it> |
| Dkim-Signature | v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=roeck-us.net; s=default; h=Content-Transfer-Encoding:Content-Type: In-Reply-To:MIME-Version:Date:Message-ID:From:Cc:References:To:Subject; bh=f5/Dtbc4TwOsx3cyofXe47cn8wXzPxjmBpCtzu7sCYg=; b=vE13t4U6aEmq2gocL+DOWJ3WDq 3syidgFP0/3LSxoXJ0s8MWDV1dQR9hhuF9/0ERmCU0/TBC1m+clCkUsFNxU1T6TeyJxc13SysBC8q d3SWQOSQ71yPcNIEGUNzeSlOjD7qgIgI2L9me1ez3BVA09H1ohwTeGso6JzMsOjmvG8f3dj34IfTK HV9LeTO8Ts9rOk6VXhRJJN1LB8bSpekvuPq39BiAzgO+YbLFwxPDD0r/mvPswr99MhZirCH1gyIF+ eb9wK18Jdl0XikP7iOnr2JlTyKmMc8ori7lfPzvDDuRikSQyAnmShgxRCUE2yIVIZaqG/hTDOFgBg HFiU7qsQ==; |
| User-Agent | Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.7.2 |
| MIME-Version | 1.0 |
| Content-Type | text/plain; charset=windows-1252; format=flowed |
| Content-Transfer-Encoding | 7bit |
| X-Authenticated_Sender | linux@roeck-us.net |
| X-Outgoing-Spam-Status | No, score=-1.0 |
| X-Antiabuse | This header was added to track abuse, please include it with any abuse report |
| X-Antiabuse | Primary Hostname - bh-25.webhostbox.net |
| X-Antiabuse | Original Domain - vger.kernel.org |
| X-Antiabuse | Originator/Caller UID/GID - [47 12] / [47 12] |
| X-Antiabuse | Sender Address Domain - roeck-us.net |
| X-Get-Message-Sender-Via | bh-25.webhostbox.net: authenticated_id: linux@roeck-us.net |
| X-Authenticated-Sender | bh-25.webhostbox.net: linux@roeck-us.net |
| Sender | robomod@news.nic.it |
| List-ID | <linux-kernel.vger.kernel.org> |
| X-Mailing-List | linux-kernel@vger.kernel.org |
| Approved | robomod@news.nic.it |
| Lines | 59 |
| Organization | linux.* mail to news gateway |
| X-Original-Cc | Linus Walleij <linus.walleij@linaro.org>, linux-kernel@vger.kernel.org, linux-arm-kernel@lists.infradead.org |
| X-Original-Date | Sat, 28 May 2016 14:17:05 -0700 |
| X-Original-Message-ID | <574A0AD1.9000304@roeck-us.net> |
| X-Original-References | <20160527202715.GA4841@roeck-us.net> <87a8jah9ok.fsf@belgarion.home> |
| X-Original-Sender | linux-kernel-owner@vger.kernel.org |
| Xref | csiph.com linux.kernel:1408524 |
Show key headers only | View raw
On 05/28/2016 01:24 AM, Robert Jarzmik wrote:
> Guenter Roeck <linux@roeck-us.net> writes:
>
>> Hi,
>>
>> your mainline commit f806dac5938b ("ARM: pxa: activate pinctrl for device-tree
>> machines") causes various non-devicetree systems to fail with the following
>> error messages when running a pxa_defconfig image.
> Ah yes, you're right.
>
>>
>> During boot:
>>
>> Can't request reset_gpio
>>
>> At reboot:
>>
>> reboot: Restarting system
>> ------------[ cut here ]------------
>> kernel BUG at arch/arm/mach-pxa/reset.c:59!
>> ...
>>
>> Added logging shows that the error seen when trying to request the reset gpio
>> is -EPROBE_DEFER, and that the pxa gpio driver is not instantiated.
>>
>> This is seen when attempting to run akita, borzoi, spitz, terrier, or tosa
>> in qemu with pxa_defconfig. Reverting your patch fixes the problem.
>>
>> Is this on purpose ?
> Well no :)
> The real reason behind is that gpio handling for pxa in its current state cannot
> be built for _both_ a devicetree machine (ie. pxa-dt.c) and a non devicetree
> machine (ie. corgi, tosa, ...).
>
> This is turn is because for devicetree a pinctrl is enforced for the machine,
> and a pinctrl driver is required. If it's not available, pxa_gpio_request()
> fails on pinctrl_request_gpio() and returns -EPROBE_DEFER.
>
> Now the true chicken and egg problem is than machine files,
> ie. arch/arm/mach-pxa/xxx.c are using gpio before the drivers are probed, in the
> init_machine() function, and that's why pinctrl/gpio for legacy machine files is
> a bit difficult.
>
>> Unless I am missing something, it effectively means that
>> pxa_defconfig no longer works for pxa3xx systems, since those do not support
>> devicetree (or at least there is no devicetree file which includes
>> pxa3xx.dtsi).
> I'd rather say that pxa_defconfig doesn't work anymore on any legacy system.
> Its first purpose was to ensure compilation coverage of all legacy pxa systems.
> Its second one was to have a single kernel bootable on all legacy pxa systems.
>
> Therefore, would you tell me if the patch in [1] fixes your issue ?
>
Yes, it does. It is actually the workaround I deployed for my test builds,
since I thought that the change was on purpose.
Thanks,
Guenter
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
pxa_defconfig runtime failures due to 'ARM: pxa: activate pinctrl for device-tree machines' Guenter Roeck <linux@roeck-us.net> - 2016-05-27 22:30 +0200
Re: pxa_defconfig runtime failures due to 'ARM: pxa: activate pinctrl for device-tree machines' Robert Jarzmik <robert.jarzmik@free.fr> - 2016-05-28 10:30 +0200
Re: pxa_defconfig runtime failures due to 'ARM: pxa: activate pinctrl for device-tree machines' Guenter Roeck <linux@roeck-us.net> - 2016-05-28 23:20 +0200
Re: pxa_defconfig runtime failures due to 'ARM: pxa: activate pinctrl for device-tree machines' Robert Jarzmik <robert.jarzmik@free.fr> - 2016-05-31 08:30 +0200
csiph-web