Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1350101

[PATCH v2 0/2] cpuacct: rename parameter in cpuusage_write for readability

From Zhao Lei <zhaolei@cn.fujitsu.com>
Newsgroups linux.kernel
Subject [PATCH v2 0/2] cpuacct: rename parameter in cpuusage_write for readability
Date 2016-03-04 11:00 +0100
Message-ID <r8UwX-4Id-25@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


The name of 'reset' makes a little confusion in reading, we would
say, if we want to reset usage, return -EINVAL. That's not true.

Actually, we want to say, we only allow user to do a reset. This
patch rename reset to val and add a comment here, making the code
more readable.

Changelog v1->v2:
1: Rebase on top of 4.5-rc6
2: Fix little spelling typo in description.
3: Fix line over 80 characters
4: Add Acked-by: Tejun Heo <tj@kernel.org>

Yang Dongsheng (2):
  cpuacct: rename parameter in cpuusage_write for readability
  cpuacct: split usage into user_usage and sys_usage.

 kernel/sched/cpuacct.c | 151 ++++++++++++++++++++++++++++++++++++++++++-------
 1 file changed, 129 insertions(+), 22 deletions(-)

-- 
1.8.5.1

Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 0/2] cpuacct: rename parameter in cpuusage_write for readability Zhao Lei <zhaolei@cn.fujitsu.com> - 2016-03-04 11:00 +0100
  [PATCH v2 2/2] cpuacct: split usage into user_usage and sys_usage. Zhao Lei <zhaolei@cn.fujitsu.com> - 2016-03-04 11:00 +0100
    Re: [PATCH v2 2/2] cpuacct: split usage into user_usage and  sys_usage. Peter Zijlstra <peterz@infradead.org> - 2016-03-10 14:30 +0100
      RE: [PATCH v2 2/2] cpuacct: split usage into user_usage and sys_usage. Zhao Lei <zhaolei@cn.fujitsu.com> - 2016-03-16 11:50 +0100

csiph-web