Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1349759

Re: [RFC PATCH 1/4] mmc: core: add cap-enhanced-strobe support

From Shawn Lin <shawn.lin@rock-chips.com>
Newsgroups linux.kernel
Subject Re: [RFC PATCH 1/4] mmc: core: add cap-enhanced-strobe support
Date 2016-03-04 02:40 +0100
Message-ID <r8MSK-7vn-5@gated-at.bofh.it> (permalink)
References <r8ruV-ms-3@gated-at.bofh.it> <r8ruW-ms-15@gated-at.bofh.it> <r8AeT-6Vw-33@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hi Jaehoon,

On 2016/3/3 20:08, Jaehoon Chung wrote:
> Hi Shawn,
>
> On 03/03/2016 11:36 AM, Shawn Lin wrote:
>> This patch introduce cap-enhanced-strobe for platforms which
>> want to enable enhanced strobe function from DT if the mmc host
>> controller claims to support enhanced strobe.
>
> I don't know why need to add the capability and property.
>

 From my point, HS400-ES is a optional feature, so we should leave it
for people to decide whether to use it. Just as my controller supports 
hs400, but I can't force all the people using my platform to use hs400?
That's why we add mmc-hs400-* in DT.

But maybe I can change the name to mmc-hs400es-* ?


[...]

>>   #define MMC_CAP_DRIVER_TYPE_A	(1 << 23)	/* Host supports Driver Type A */
>>   #define MMC_CAP_DRIVER_TYPE_C	(1 << 24)	/* Host supports Driver Type C */
>>   #define MMC_CAP_DRIVER_TYPE_D	(1 << 25)	/* Host supports Driver Type D */
>> +#define MMC_CAP_ENHANCED_STROBE	(1 << 20)	/* Host supports enhanced strobe */
>
> Need to fix ordering.

yeah~~ good catch!

>
>>   #define MMC_CAP_CMD23		(1 << 30)	/* CMD23 supported. */
>>   #define MMC_CAP_HW_RESET	(1 << 31)	/* Hardware reset */
>>
>> @@ -469,6 +470,11 @@ static inline int mmc_host_uhs(struct mmc_host *host)
>>   		 MMC_CAP_UHS_DDR50);
>>   }
>>
>> +static inline int mmc_host_enhanced_strobe(struct mmc_host *host)
>> +{
>> +	return host->caps & MMC_CAP_ENHANCED_STROBE;
>> +}
>> +
>>   static inline int mmc_host_packed_wr(struct mmc_host *host)
>>   {
>>   	return host->caps2 & MMC_CAP2_PACKED_WR;
>>
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-mmc" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
>


-- 
Best Regards
Shawn Lin

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[RFC PATCH 0/4] Add enhanced strobe support for emmc version 5.1 or later Shawn Lin <shawn.lin@rock-chips.com> - 2016-03-03 03:50 +0100
  [RFC PATCH 1/4] mmc: core: add cap-enhanced-strobe support Shawn Lin <shawn.lin@rock-chips.com> - 2016-03-03 03:50 +0100
    Re: [RFC PATCH 1/4] mmc: core: add cap-enhanced-strobe support Jaehoon Chung <jh80.chung@samsung.com> - 2016-03-03 13:10 +0100
      Re: [RFC PATCH 1/4] mmc: core: add cap-enhanced-strobe support Shawn Lin <shawn.lin@rock-chips.com> - 2016-03-04 02:40 +0100
  [RFC PATCH 2/4] mmc: core: implement enhanced strobe support Shawn Lin <shawn.lin@rock-chips.com> - 2016-03-03 03:50 +0100
    Re: [RFC PATCH 2/4] mmc: core: implement enhanced strobe support Adrian Hunter <adrian.hunter@intel.com> - 2016-03-03 14:50 +0100
      Re: [RFC PATCH 2/4] mmc: core: implement enhanced strobe support Shawn Lin <shawn.lin@kernel-upstream.org> - 2016-03-04 03:10 +0100

csiph-web