Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1342966
| From | Xiao Guangrong <guangrong.xiao@linux.intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 00/12] KVM: MMU: cleanup around kvm_sync_page, and a few micro-optimizations |
| Date | 2016-02-25 09:30 +0100 |
| Message-ID | <r5Zt9-120-25@gated-at.bofh.it> (permalink) |
| References | <r5Hwe-543-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 02/24/2016 09:17 PM, Paolo Bonzini wrote: > This series started from looking at mmu_unsync_walk for the ubsan thread. > Patches 1 and 2 are the result of the discussions in that thread. > > Patches 3 to 9 do more cleanups in __kvm_sync_page and its callers. > Among other changes, it removes kvm_sync_page_transient and avoids > duplicate code between __kvm_sync_page and kvm_sync_pages. > > I stopped where I had questions about the existing kvm_mmu_get_page > code (see patch 8 for the question). However perhaps more cleanups > are possible, also thanks to Takuya's work on that function and > link_shadow_page. > > Patches 10 to 12 are just micro-optimizations. > > Guangrong, it would be great if you took a look since you know this part > of KVM very well. I have reviewed it and it works fine except the one leaking tlb flush out of mmu-lock. I will continue to simplify the path of walking unsync sp to keep mmu_page_path smaller and make comments for kvm_mmu_get_page on top of this patchset. BTW, is any conflict to apply my page-tracking patchset on top of this patchset (i noticed you've merged this patchset on kvm/queue)? Please tell me to rebase it if it is needed.
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/12] KVM: MMU: cleanup around kvm_sync_page, and a few micro-optimizations Paolo Bonzini <pbonzini@redhat.com> - 2016-02-24 14:20 +0100
[PATCH 10/12] KVM: mark memory barrier with smp_mb__after_atomic Paolo Bonzini <pbonzini@redhat.com> - 2016-02-24 14:20 +0100
[PATCH 05/12] KVM: MMU: use kvm_sync_page in kvm_sync_pages Paolo Bonzini <pbonzini@redhat.com> - 2016-02-24 14:30 +0100
[PATCH 08/12] KVM: MMU: move zap/flush to kvm_mmu_get_page Paolo Bonzini <pbonzini@redhat.com> - 2016-02-24 14:30 +0100
Re: [PATCH 08/12] KVM: MMU: move zap/flush to kvm_mmu_get_page Xiao Guangrong <guangrong.xiao@linux.intel.com> - 2016-02-25 08:40 +0100
Re: [PATCH 08/12] KVM: MMU: move zap/flush to kvm_mmu_get_page Paolo Bonzini <pbonzini@redhat.com> - 2016-02-25 09:50 +0100
[PATCH 02/12] KVM: MMU: check kvm_mmu_pages and mmu_page_path indices Paolo Bonzini <pbonzini@redhat.com> - 2016-02-24 14:30 +0100
[PATCH 03/12] KVM: MMU: introduce kvm_mmu_flush_or_zap Paolo Bonzini <pbonzini@redhat.com> - 2016-02-24 14:30 +0100
[PATCH 04/12] KVM: MMU: move TLB flush out of __kvm_sync_page Paolo Bonzini <pbonzini@redhat.com> - 2016-02-24 14:30 +0100
Re: [PATCH 00/12] KVM: MMU: cleanup around kvm_sync_page, and a few micro-optimizations Xiao Guangrong <guangrong.xiao@linux.intel.com> - 2016-02-25 09:30 +0100
Re: [PATCH 00/12] KVM: MMU: cleanup around kvm_sync_page, and a few micro-optimizations Paolo Bonzini <pbonzini@redhat.com> - 2016-02-25 09:50 +0100
csiph-web