Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1341692

Re: [PATCH 03/27] mm, vmstat: Add infrastructure for per-node vmstats

From Mel Gorman <mgorman@techsingularity.net>
Newsgroups linux.kernel
Subject Re: [PATCH 03/27] mm, vmstat: Add infrastructure for per-node vmstats
Date 2016-02-24 10:20 +0100
Message-ID <r5DLX-2n7-9@gated-at.bofh.it> (permalink)
References <r5mL7-7at-5@gated-at.bofh.it> <r5mUO-7eb-35@gated-at.bofh.it> <r5pJ1-G1-29@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, Feb 23, 2016 at 10:13:18AM -0800, Johannes Weiner wrote:
> On Tue, Feb 23, 2016 at 03:04:26PM +0000, Mel Gorman wrote:
> > VM statistic counters for reclaim decisions are zone-based. If the kernel
> > is to reclaim on a per-node basis then we need to track per-node statistics
> > but there is no infrastructure for that. The most notable change is that
> > the old node_page_state is renamed to sum_zone_node_page_state.  The new
> > node_page_state takes a pglist_data and uses per-node stats but none exist
> > yet. There is some renaming such as vm_stat to vm_zone_stat and the addition
> > of vm_node_stat and the renaming of mod_state to mod_zone_state. Otherwise,
> > this is mostly a mechanical patch with no functional change. There is a
> > lot of similarity between the node and zone helpers which is unfortunate
> > but there was no obvious way of reusing the code and maintaining type safety.
> > 
> > Signed-off-by: Mel Gorman <mgorman@techsingularity.net>
> 
> Hopefully we can eventually ditch /proc/zoneinfo in favor of a
> /proc/nodeinfo and get rid of the per-zone stats accounting.
> 

It may not be possible to ditch /proc/zoneinfo entirely but a /proc/nodeinfo
would make sense. It may interfere with userspace that's aware of kernel
internals but that may be manageable.

> In general, this patch looks good to me.
> 
> Acked-by: Johannes Weiner <hannes@cmpxchg.org>
> 

Thanks.

> Only one thing I noticed:
> 
> > @@ -349,12 +349,14 @@ static unsigned long count_shadow_nodes(struct shrinker *shrinker,
> >  	shadow_nodes = list_lru_shrink_count(&workingset_shadow_nodes, sc);
> >  	local_irq_enable();
> >  
> > -	if (memcg_kmem_enabled())
> > +	if (memcg_kmem_enabled()) {
> >  		pages = mem_cgroup_node_nr_lru_pages(sc->memcg, sc->nid,
> >  						     LRU_ALL_FILE);
> > -	else
> > -		pages = node_page_state(sc->nid, NR_ACTIVE_FILE) +
> > -			node_page_state(sc->nid, NR_INACTIVE_FILE);
> > +	} else {
> > +		pg_data_t *pgdat = NODE_DATA(sc->nid);
> > +		pages = node_page_state(pgdat, NR_ACTIVE_FILE) +
> > +			node_page_state(pgdat, NR_INACTIVE_FILE);
> > +	}
> 
> That should also be sum_zone_node_page_state, right? These are not
> valid node items (yet).

Yep, not for another two patches. Fixed now.

-- 
Mel Gorman
SUSE Labs

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[RFC PATCH 00/27] Move LRU page reclaim from zones to nodes v2 Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:10 +0100
  [PATCH 06/27] mm, vmscan: Begin reclaiming pages on a per-node basis Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:10 +0100
    Re: [PATCH 06/27] mm, vmscan: Begin reclaiming pages on a per-node  basis Johannes Weiner <hannes@cmpxchg.org> - 2016-02-23 20:00 +0100
      Re: [PATCH 06/27] mm, vmscan: Begin reclaiming pages on a per-node  basis Johannes Weiner <hannes@cmpxchg.org> - 2016-02-23 20:10 +0100
      Re: [PATCH 06/27] mm, vmscan: Begin reclaiming pages on a per-node  basis Mel Gorman <mgorman@techsingularity.net> - 2016-02-24 11:30 +0100
  [PATCH 15/27] mm, workingset: Make working set detection node-aware Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:10 +0100
    Re: [PATCH 15/27] mm, workingset: Make working set detection  node-aware Johannes Weiner <hannes@cmpxchg.org> - 2016-02-28 17:20 +0100
  [PATCH 13/27] mm, vmscan: Make shrink_node decisions more node-centric Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:10 +0100
  [PATCH 09/27] mm, vmscan: Simplify the logic deciding whether kswapd sleeps Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:10 +0100
    Re: [PATCH 09/27] mm, vmscan: Simplify the logic deciding whether  kswapd sleeps Johannes Weiner <hannes@cmpxchg.org> - 2016-02-28 17:20 +0100
  [PATCH 10/27] mm, vmscan: By default have direct reclaim only shrink once per node Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:10 +0100
    Re: [PATCH 10/27] mm, vmscan: By default have direct reclaim only  shrink once per node Johannes Weiner <hannes@cmpxchg.org> - 2016-02-28 17:20 +0100
  [PATCH 12/27] mm: vmscan: Do not reclaim from kswapd if there is any eligible zone Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:10 +0100
  [PATCH 07/27] mm, vmscan: Have kswapd only scan based on the highest requested zone Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:20 +0100
    Re: [PATCH 07/27] mm, vmscan: Have kswapd only scan based on the  highest requested zone Johannes Weiner <hannes@cmpxchg.org> - 2016-02-25 23:20 +0100
  [PATCH 19/27] mm: Move most file-based accounting to the node Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:20 +0100
  [PATCH 18/27] mm: Rename NR_ANON_PAGES to NR_ANON_MAPPED Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:20 +0100
  [PATCH 01/27] mm, page_alloc: Use ac->classzone_idx instead of zone_idx(preferred_zone) Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:20 +0100
    Re: [PATCH 01/27] mm, page_alloc: Use ac->classzone_idx instead of  zone_idx(preferred_zone) Johannes Weiner <hannes@cmpxchg.org> - 2016-02-23 19:10 +0100
    Re: [PATCH 01/27] mm, page_alloc: Use ac->classzone_idx instead of  zone_idx(preferred_zone) Vlastimil Babka <vbabka@suse.cz> - 2016-03-03 11:40 +0100
  [PATCH 04/27] mm, vmscan: Move lru_lock to the node Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:20 +0100
    Re: [PATCH 04/27] mm, vmscan: Move lru_lock to the node Johannes Weiner <hannes@cmpxchg.org> - 2016-02-23 19:50 +0100
  [PATCH 17/27] mm: Move page mapped accounting to the node Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:20 +0100
  [PATCH 03/27] mm, vmstat: Add infrastructure for per-node vmstats Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:20 +0100
    Re: [PATCH 03/27] mm, vmstat: Add infrastructure for per-node vmstats Johannes Weiner <hannes@cmpxchg.org> - 2016-02-23 19:20 +0100
      Re: [PATCH 03/27] mm, vmstat: Add infrastructure for per-node vmstats Mel Gorman <mgorman@techsingularity.net> - 2016-02-24 10:20 +0100
  [PATCH 21/27] mm, vmscan: Update classzone_idx if  buffer_heads_over_limit Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:20 +0100
  [PATCH 11/27] mm, vmscan: Clear congestion, dirty and need for compaction on a per-node basis Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:20 +0100
  [PATCH 16/27] mm, page_alloc: Consider dirtyable memory in terms of  nodes Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:20 +0100
    Re: [PATCH 16/27] mm, page_alloc: Consider dirtyable memory in terms  of nodes Johannes Weiner <hannes@cmpxchg.org> - 2016-02-28 17:20 +0100
  [PATCH 20/27] mm: Move vmscan writes and file write accounting to  the node Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:20 +0100
  [PATCH 02/27] mm, vmscan: Check if cpusets are enabled during direct reclaim Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:20 +0100
    Re: [PATCH 02/27] mm, vmscan: Check if cpusets are enabled during  direct reclaim Johannes Weiner <hannes@cmpxchg.org> - 2016-02-23 19:10 +0100
    Re: [PATCH 02/27] mm, vmscan: Check if cpusets are enabled during  direct reclaim Vlastimil Babka <vbabka@suse.cz> - 2016-03-03 12:40 +0100
  [PATCH 27/27] mm: page_alloc: Cache the last node whose dirty limit  is reached Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:30 +0100
  [PATCH 25/27] mm, vmscan: Add classzone information to tracepoints Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:30 +0100
  [PATCH 23/27] mm, vmscan: Account in vmstat for pages skipped during  reclaim Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:30 +0100
  [PATCH 22/27] mm, vmscan: Only wakeup kswapd once per node for the  requested classzone Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:30 +0100
  [PATCH 24/27] mm: Convert zone_reclaim to node_reclaim Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:30 +0100
  [PATCH 26/27] mm, page_alloc: Remove fair zone allocation policy Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 16:30 +0100
  Re: [RFC PATCH 00/27] Move LRU page reclaim from zones to nodes v2 Christoph Lameter <cl@linux.com> - 2016-02-23 18:20 +0100
  Re: [PATCH 05/27] mm, vmscan: Move LRU lists to node Johannes Weiner <hannes@cmpxchg.org> - 2016-02-23 19:50 +0100
  Re: [RFC PATCH 00/27] Move LRU page reclaim from zones to nodes v2 Johannes Weiner <hannes@cmpxchg.org> - 2016-02-23 21:10 +0100
    Re: [RFC PATCH 00/27] Move LRU page reclaim from zones to nodes v2 Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 21:20 +0100
      Re: [RFC PATCH 00/27] Move LRU page reclaim from zones to nodes v2 Johannes Weiner <hannes@cmpxchg.org> - 2016-02-23 22:00 +0100
        Re: [RFC PATCH 00/27] Move LRU page reclaim from zones to nodes v2 Mel Gorman <mgorman@techsingularity.net> - 2016-02-23 23:00 +0100
          Re: [RFC PATCH 00/27] Move LRU page reclaim from zones to nodes v2 Johannes Weiner <hannes@cmpxchg.org> - 2016-02-24 01:20 +0100
            Re: [RFC PATCH 00/27] Move LRU page reclaim from zones to nodes v2 Mel Gorman <mgorman@techsingularity.net> - 2016-02-24 11:50 +0100

csiph-web