Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1336495
| From | Toshi Kani <toshi.kani@hpe.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v3 1/2] x86/lib/copy_user_64.S: cleanup __copy_user_nocache() |
| Date | 2016-02-17 16:00 +0100 |
| Message-ID | <r3bKa-7NK-7@gated-at.bofh.it> (permalink) |
| References | <r16bT-5r2-3@gated-at.bofh.it> <r16bU-5r2-7@gated-at.bofh.it> <r35lo-3zq-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Wed, 2016-02-17 at 09:02 +0100, Ingo Molnar wrote: > * Toshi Kani <toshi.kani@hpe.com> wrote: > > > Add comments to __copy_user_nocache() to clarify its procedures > > and alignment requirement. > > > > Also change numeric branch target labels to named labels. The > > labels begin with ".L" and prefix "cun" (Copy User Nocache) to > > keep them local and unique to the function. > > So the .L labels are local, i.e. they are not emitted into the symbol > table. > > I.e. no need to name them globally! Right, but I thought there is risk of conflicting the names with other copy functions in the file when they also start using descriptive labels. For instance, ".L_finish_copy" can be easily used by other copy functions as well. > I've done a s/Lcun_/L_/ over the patch. Thanks, -Toshi
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v3 1/2] x86/lib/copy_user_64.S: cleanup __copy_user_nocache() Toshi Kani <toshi.kani@hpe.com> - 2016-02-11 21:40 +0100
Re: [PATCH v3 1/2] x86/lib/copy_user_64.S: cleanup __copy_user_nocache() Ingo Molnar <mingo@kernel.org> - 2016-02-17 09:10 +0100
Re: [PATCH v3 1/2] x86/lib/copy_user_64.S: cleanup __copy_user_nocache() Toshi Kani <toshi.kani@hpe.com> - 2016-02-17 16:00 +0100
[tip:x86/urgent] x86/uaccess/64: Make the __copy_user_nocache() assembly code more readable tip-bot for Toshi Kani <tipbot@zytor.com> - 2016-02-17 13:20 +0100
csiph-web