Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1336160
| From | Ingo Molnar <mingo@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v5] x86/setup: get ramdisk parameters only once |
| Date | 2016-02-17 10:30 +0100 |
| Message-ID | <r36AO-4lp-11@gated-at.bofh.it> (permalink) |
| References | <r36r8-4hD-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
* Alexander Kuleshov <kuleshovmail@gmail.com> wrote: > - early_reserve_initrd(); > + if (!boot_params.hdr.type_of_loader || !ramdisk_image.start_addr || !ramdisk_image.size) > + ramdisk_image.reserve_ramdisk = false; /* No initrd provided by bootloader */ > + else > + memblock_reserve(ramdisk_image.start_addr, ramdisk_image.size); ... and _now_ it's clear that it makes sense to keep early_reserve_initrd(), move that new chunk of code to it and pass in the ramdisk structure. Also, please rename the too long 'ramdisk_image' local variable to something shorter: 'rd' is commonly used - but the original 'ramdisk' name was fine too. Thanks, Ingo
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v5] x86/setup: get ramdisk parameters only once Alexander Kuleshov <kuleshovmail@gmail.com> - 2016-02-17 10:20 +0100 Re: [PATCH v5] x86/setup: get ramdisk parameters only once Ingo Molnar <mingo@kernel.org> - 2016-02-17 10:30 +0100
csiph-web