Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1334833
| From | Radim Krcmar <rkrcmar@redhat.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 4/4] Drivers: hv: vmbus: avoid unneeded compiler optimizations in vmbus_wait_for_unload() |
| Date | 2016-02-15 22:20 +0100 |
| Message-ID | <r2yIO-6Cx-3@gated-at.bofh.it> (permalink) |
| References | <r1o8N-tk-7@gated-at.bofh.it> <r1o8O-tk-39@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
2016-02-12 16:42+0100, Vitaly Kuznetsov: > Message header is modified by the hypervisor and we read it in a loop, > we need to prevent compilers from optimizing accesses. There are no such > optimizations at this moment, this is just a future proof. > > Suggested-by: Radim Krcmar <rkrcmar@redhat.com> Reviewed-by: Radim Krčmář <rkrcmar@redhat.com> > Signed-off-by: Vitaly Kuznetsov <vkuznets@redhat.com>
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 0/4] Drivers: hv: vmbus: bugfix and improvements for message handling Vitaly Kuznetsov <vkuznets@redhat.com> - 2016-02-12 16:50 +0100
[PATCH 1/4] Drivers: hv: vmbus: don't loose HVMSG_TIMER_EXPIRED messages Vitaly Kuznetsov <vkuznets@redhat.com> - 2016-02-12 16:50 +0100
Re: [PATCH 1/4] Drivers: hv: vmbus: don't loose HVMSG_TIMER_EXPIRED messages Radim Krcmar <rkrcmar@redhat.com> - 2016-02-15 22:00 +0100
[PATCH 2/4] Drivers: hv: vmbus: avoid wait_for_completion() on crash Vitaly Kuznetsov <vkuznets@redhat.com> - 2016-02-12 16:50 +0100
Re: [PATCH 2/4] Drivers: hv: vmbus: avoid wait_for_completion() on crash Radim Krcmar <rkrcmar@redhat.com> - 2016-02-15 22:10 +0100
[PATCH 3/4] Drivers: hv: vmbus: remove code duplication in message handling Vitaly Kuznetsov <vkuznets@redhat.com> - 2016-02-12 16:50 +0100
Re: [PATCH 3/4] Drivers: hv: vmbus: remove code duplication in message handling Radim Krcmar <rkrcmar@redhat.com> - 2016-02-15 22:10 +0100
[PATCH 4/4] Drivers: hv: vmbus: avoid unneeded compiler optimizations in vmbus_wait_for_unload() Vitaly Kuznetsov <vkuznets@redhat.com> - 2016-02-12 16:50 +0100
Re: [PATCH 4/4] Drivers: hv: vmbus: avoid unneeded compiler optimizations in vmbus_wait_for_unload() Radim Krcmar <rkrcmar@redhat.com> - 2016-02-15 22:20 +0100
csiph-web