Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1334578

Re: [PATCH v3 5/5] Staging: rtl8188eu/core: make core more readable

From Colin Vidal <colin@cvidal.org>
Newsgroups linux.kernel
Subject Re: [PATCH v3 5/5] Staging: rtl8188eu/core: make core more readable
Date 2016-02-15 17:30 +0100
Message-ID <r2ucb-3qG-51@gated-at.bofh.it> (permalink)
References (1 earlier) <r1qkk-24n-29@gated-at.bofh.it> <r1qkj-24n-25@gated-at.bofh.it> <r1qkk-24n-39@gated-at.bofh.it> <r1qkk-24n-37@gated-at.bofh.it> <r2fmQ-1Of-57@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Sun, 2016-02-14 at 16:39 -0800, Greg Kroah-Hartman wrote:
> On Fri, Feb 12, 2016 at 07:05:53PM +0100, Colin Vidal wrote:
> > Signed-off-by: Colin Vidal <colin@cvidal.org>
> > ---
> >  drivers/staging/rtl8188eu/core/rtw_iol.c | 10 +++-------
> >  1 file changed, 3 insertions(+), 7 deletions(-)
> > 
> > diff --git a/drivers/staging/rtl8188eu/core/rtw_iol.c
> > b/drivers/staging/rtl8188eu/core/rtw_iol.c
> > index 2e2145c..ba6c492 100644
> > --- a/drivers/staging/rtl8188eu/core/rtw_iol.c
> > +++ b/drivers/staging/rtl8188eu/core/rtw_iol.c
> > @@ -18,11 +18,7 @@
> >  
> >  bool rtw_IOL_applied(struct adapter *adapter)
> >  {
> > -	if (adapter->registrypriv.fw_iol == 1)
> > -		return true;
> > -
> > -	if ((adapter->registrypriv.fw_iol == 2) &&
> > -	    (!adapter_to_dvobj(adapter)->ishighspeed))
> > -		return true;
> > -	return false;
> > +	return adapter->registrypriv.fw_iol == 1 ||
> > +		(adapter->registrypriv.fw_iol == 2 &&
> > +		 !adapter_to_dvobj(adapter)->ishighspeed);
> >  }
> 
> I'm sorry, but this patch does not do what you said it does, it's
> much
> harder to read now :(
> 
> Also, I can't take a patch without a changelog text :(
> 
> thanks,
> 
> greg k-h

Hi Greg,

Thanks for you replie!

OK, I thought it was a better idea (as suggests Joe Perches) to group
the test in a way to avoid multiples - and maybe confusing - returns.
So, I'll remove this one.

Sorry about the changelot, I missed it while making patch series, I'll
resend it.

Thanks,

Colin

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v3 3/5] Staging: rtl8188eu/core: Coding style fix, set constant operand on right in tests Colin Vidal <colin@cvidal.org> - 2016-02-12 19:10 +0100
  [PATCH v3 5/5] Staging: rtl8188eu/core: make core more readable Colin Vidal <colin@cvidal.org> - 2016-02-12 19:10 +0100
    Re: [PATCH v3 5/5] Staging: rtl8188eu/core: make core more readable Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2016-02-15 01:40 +0100
      Re: [PATCH v3 5/5] Staging: rtl8188eu/core: make core more readable Colin Vidal <colin@cvidal.org> - 2016-02-15 17:30 +0100
  [PATCH v3 4/5] Staging: rtl8188eu/core: Coding style fix, avoid line over 80 characters Colin Vidal <colin@cvidal.org> - 2016-02-12 19:10 +0100

csiph-web