Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1333568

Re: [PATCH V5 04/11] soc: mediatek: PMIC wrap: split SoC specific init into callback

From John Crispin <blogic@openwrt.org>
Newsgroups linux.kernel
Subject Re: [PATCH V5 04/11] soc: mediatek: PMIC wrap: split SoC specific init into callback
Date 2016-02-14 22:10 +0100
Message-ID <r2c5z-8dS-1@gated-at.bofh.it> (permalink)
References <qZv4K-4R0-5@gated-at.bofh.it> <qZv4K-4R0-15@gated-at.bofh.it> <r0Y4G-8bX-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw



On 11/02/2016 12:54, Matthias Brugger wrote:
>> diff --git a/drivers/soc/mediatek/mtk-pmic-wrap.c
>> b/drivers/soc/mediatek/mtk-pmic-wrap.c
>> index b22b664..e3bbee5 100644
>> --- a/drivers/soc/mediatek/mtk-pmic-wrap.c
>> +++ b/drivers/soc/mediatek/mtk-pmic-wrap.c
>> @@ -372,6 +372,7 @@ struct pmic_wrapper_type {
>>       enum pwrap_type type;
>>       u32 arb_en_all;
>>       int (*init_reg_clock)(struct pmic_wrapper *wrp);
>> +    int (*init_special)(struct pmic_wrapper *wrp);
> 
> Nit:
> I wonder if we can find a better name for the callback, as init_special
> sounds quite generic to me.
> 
> Thanks,
> Matthias

Hi,

At first I considered enable_wrapper as the mt8135/8173 code seems to do
just that. however mt2701 does an init of the ADC. So how about using
init_soc_specific ?

	John

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [PATCH V5 04/11] soc: mediatek: PMIC wrap: split SoC specific  init into callback Matthias Brugger <matthias.bgg@gmail.com> - 2016-02-11 13:00 +0100
  Re: [PATCH V5 04/11] soc: mediatek: PMIC wrap: split SoC specific  init into callback John Crispin <blogic@openwrt.org> - 2016-02-14 22:10 +0100
    Re: [PATCH V5 04/11] soc: mediatek: PMIC wrap: split SoC specific  init into callback Matthias Brugger <matthias.bgg@gmail.com> - 2016-02-17 18:00 +0100

csiph-web