Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1332407
| From | "Rafael J. Wysocki" <rjw@rjwysocki.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v4 01/17] Xen: ACPI: Hide UART used by Xen |
| Date | 2016-02-11 23:30 +0100 |
| Message-ID | <r17Um-6Bj-3@gated-at.bofh.it> (permalink) |
| References | <qYEWt-2Kf-5@gated-at.bofh.it> <r0LqO-8kt-15@gated-at.bofh.it> <r11YD-2Ij-49@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thursday, February 11, 2016 04:04:14 PM Stefano Stabellini wrote:
> On Wed, 10 Feb 2016, Rafael J. Wysocki wrote:
> > On Tuesday, February 09, 2016 11:19:02 AM Stefano Stabellini wrote:
> > > On Mon, 8 Feb 2016, Rafael J. Wysocki wrote:
> > > > On Monday, February 08, 2016 10:57:01 AM Stefano Stabellini wrote:
> > > > > On Sat, 6 Feb 2016, Rafael J. Wysocki wrote:
> > > > > > On Fri, Feb 5, 2016 at 4:05 AM, Shannon Zhao <zhaoshenglong@huawei.com> wrote:
> > > > > > > From: Shannon Zhao <shannon.zhao@linaro.org>
> > > > > > >
> > > > > > > ACPI 6.0 introduces a new table STAO to list the devices which are used
> > > > > > > by Xen and can't be used by Dom0. On Xen virtual platforms, the physical
> > > > > > > UART is used by Xen. So here it hides UART from Dom0.
> > > > > > >
> > > > > > > Signed-off-by: Shannon Zhao <shannon.zhao@linaro.org>
> > > > > > > Reviewed-by: Stefano Stabellini <stefano.stabellini@eu.citrix.com>
> > > > > >
> > > > > > Well, this doesn't look right to me.
> > > > > >
> > > > > > We need to find a nicer way to achieve what you want.
> > > > >
> > > > > I take that you are talking about how to honor the STAO table in Linux.
> > > > > Do you have any concrete suggestions?
> > > >
> > > > I do.
> > > >
> > > > The last hunk of the patch is likely what it needs to be, although I'm
> > > > not sure if the place it is added to is the right one. That's a minor thing,
> > > > though.
> > > >
> > > > The other part is problematic. Not that as it doesn't work, but because of
> > > > how it works. With these changes the device will be visible to the OS (in
> > > > fact to user space even), but will never be "present". I'm not sure if
> > > > that's what you want?
> > > >
> > > > It might be better to add a check to acpi_bus_type_and_status() that will
> > > > evaluate the "should ignore?" thing and return -ENODEV if this is true. This
> > > > way the device won't be visible at all.
> > >
> > > Something like below? Actually your suggestion is better, thank you!
> > >
> > > diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c
> > > index 78d5f02..4778c51 100644
> > > --- a/drivers/acpi/scan.c
> > > +++ b/drivers/acpi/scan.c
> > > @@ -1455,6 +1455,9 @@ static int acpi_bus_type_and_status(acpi_handle handle, int *type,
> > > if (ACPI_FAILURE(status))
> > > return -ENODEV;
> > >
> > > + if (acpi_check_device_is_ignored(handle))
> > > + return -ENODEV;
> > > +
> > > switch (acpi_type) {
> > > case ACPI_TYPE_ANY: /* for ACPI_ROOT_OBJECT */
> > > case ACPI_TYPE_DEVICE:
> > >
> >
> > I thought about doing that under ACPI_TYPE_DEVICE, because it shouldn't be
> > applicable to the other types. But generally, yes.
>
> I was pondering about it myself. Maybe an ACPI_TYPE_PROCESSOR object
> could theoretically be hidden with the STAO?
But this patch won't check for it anyway, will it?
It seems to be only checking against the UART address or have I missed
anything?
> I added the check before
> the switch because I thought that there would be no harm in being
> caution about it.
>
>
> > Plus I'd move the table checks to acpi_scan_init(), so the UART address can
> > be a static variable in scan.c.
> >
> > Also maybe rename acpi_check_device_is_ignored() to something like
> > acpi_device_should_be_hidden().
>
> Both make sense. Shannon, are you happy to make these changes?
Plus maybe make acpi_device_should_be_hidden() print a (KERN_INFO) message
when it decides to hide something?
Thanks,
Rafael
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Re: [PATCH v4 01/17] Xen: ACPI: Hide UART used by Xen Stefano Stabellini <stefano.stabellini@eu.citrix.com> - 2016-02-09 12:20 +0100
Re: [PATCH v4 01/17] Xen: ACPI: Hide UART used by Xen "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2016-02-10 23:30 +0100
Re: [PATCH v4 01/17] Xen: ACPI: Hide UART used by Xen Stefano Stabellini <stefano.stabellini@eu.citrix.com> - 2016-02-11 17:10 +0100
Re: [PATCH v4 01/17] Xen: ACPI: Hide UART used by Xen "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2016-02-11 23:30 +0100
Re: [PATCH v4 01/17] Xen: ACPI: Hide UART used by Xen Stefano Stabellini <stefano.stabellini@eu.citrix.com> - 2016-02-12 13:00 +0100
Re: [PATCH v4 01/17] Xen: ACPI: Hide UART used by Xen "Rafael J. Wysocki" <rafael@kernel.org> - 2016-02-12 14:00 +0100
csiph-web