Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1330538
| From | Manoj Kumar <manoj@linux.vnet.ibm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/6] ibmvscsi: Add and use enums for valid CRQ header values |
| Date | 2016-02-09 18:50 +0100 |
| Message-ID | <r0kAi-7lb-19@gated-at.bofh.it> (permalink) |
| References | <qYf24-oH-53@gated-at.bofh.it> <qYfbI-uu-19@gated-at.bofh.it> <qYyen-6s7-13@gated-at.bofh.it> <qYzDs-7yk-7@gated-at.bofh.it> |
| Organization | IBM |
> Yeah, I can see how that is confusing. Since, all three possible valid > crq message types have the first bit set I think this was originally a > cute hack to grab anything that was likely valid. Then in > ibmvscsi_handle_crq() we explicitly match the full header value in a > switch statement logging anything that turned out actually invalid. > >> >> If 'valid' will only have one of these four enums defined, would >> this be better written as: >> >> if (crq->valid != VIOSRP_CRQ_FREE) > > This definitely would make the logic easier to read and follow. Also, > this would make sure any crq with an invalid header that doesn't have > its first bit set will also be logged by the ibmvscsi_handle_crq() > switch statement default block and not silently ignored. > > -Tyrel Sounds good, Tyrel. Does this mean I should expect a v2 of this patch series? - Manoj N. Kumar
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Re: [PATCH 2/6] ibmvscsi: Add and use enums for valid CRQ header values Manoj Kumar <manoj@linux.vnet.ibm.com> - 2016-02-09 18:50 +0100 Re: [PATCH 2/6] ibmvscsi: Add and use enums for valid CRQ header values Tyrel Datwyler <tyreld@linux.vnet.ibm.com> - 2016-02-09 19:30 +0100
csiph-web