Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1330183
| From | tip-bot for Borislav Petkov <tipbot@zytor.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [tip:x86/microcode] x86/microcode/intel: Cleanup apply_microcode_intel() |
| Date | 2016-02-09 13:30 +0100 |
| Message-ID | <r0fAD-3Wc-39@gated-at.bofh.it> (permalink) |
| References | <qY46C-1pi-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Commit-ID: 26cbaa4dc676a444aa626cbc642c4c8181ef1378
Gitweb: http://git.kernel.org/tip/26cbaa4dc676a444aa626cbc642c4c8181ef1378
Author: Borislav Petkov <bp@suse.de>
AuthorDate: Wed, 3 Feb 2016 12:33:39 +0100
Committer: Ingo Molnar <mingo@kernel.org>
CommitDate: Tue, 9 Feb 2016 11:41:17 +0100
x86/microcode/intel: Cleanup apply_microcode_intel()
Get rid of local variable cpu_num as it is equal to @cpu now. Deref
cpu_data() only when it is really needed at the end.
No functionality change.
Tested-by: Thomas Voegtle <tv@lio96.de>
Signed-off-by: Borislav Petkov <bp@suse.de>
Cc: Linus Torvalds <torvalds@linux-foundation.org>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Thomas Gleixner <tglx@linutronix.de>
Link: http://lkml.kernel.org/r/1454499225-21544-12-git-send-email-bp@alien8.de
Signed-off-by: Ingo Molnar <mingo@kernel.org>
---
arch/x86/kernel/cpu/microcode/intel.c | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)
diff --git a/arch/x86/kernel/cpu/microcode/intel.c b/arch/x86/kernel/cpu/microcode/intel.c
index c029c2b..35186a0 100644
--- a/arch/x86/kernel/cpu/microcode/intel.c
+++ b/arch/x86/kernel/cpu/microcode/intel.c
@@ -839,12 +839,11 @@ static int apply_microcode_intel(int cpu)
{
struct microcode_intel *mc;
struct ucode_cpu_info *uci;
+ struct cpuinfo_x86 *c;
unsigned int val[2];
- int cpu_num = raw_smp_processor_id();
- struct cpuinfo_x86 *c = &cpu_data(cpu_num);
/* We should bind the task to the CPU */
- if (WARN_ON(cpu_num != cpu))
+ if (WARN_ON(raw_smp_processor_id() != cpu))
return -1;
uci = ucode_cpu_info + cpu;
@@ -874,15 +873,18 @@ static int apply_microcode_intel(int cpu)
if (val[1] != mc->hdr.rev) {
pr_err("CPU%d update to revision 0x%x failed\n",
- cpu_num, mc->hdr.rev);
+ cpu, mc->hdr.rev);
return -1;
}
+
pr_info("CPU%d updated to revision 0x%x, date = %04x-%02x-%02x\n",
- cpu_num, val[1],
+ cpu, val[1],
mc->hdr.date & 0xffff,
mc->hdr.date >> 24,
(mc->hdr.date >> 16) & 0xff);
+ c = &cpu_data(cpu);
+
uci->cpu_sig.rev = val[1];
c->microcode = val[1];
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/17] x86/microcode: Untangle loader from BLK_DEV_INITRD Borislav Petkov <bp@alien8.de> - 2016-02-03 12:40 +0100
[PATCH 02/17] x86/microcode/intel: Make early loader look for builtin microcode too Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode/intel: Make early loader look for builtin microcode too tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-02-09 13:30 +0100
[PATCH 07/17] x86/microcode/intel: Rename local variables of type struct mc_saved_data Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode/intel: Rename local variables of type struct mc_saved_data tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-02-09 13:30 +0100
[PATCH 12/17] x86/microcode/intel: Use *wrmsrl variants Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode/intel: Use *wrmsrl variants tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-02-09 13:30 +0100
[PATCH 10/17] x86/microcode/intel: Move the BUG_ON up and turn it into WARN_ON Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode/intel: Move the BUG_ON up and turn it into WARN_ON tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-02-09 13:30 +0100
[PATCH 05/17] x86/microcode: Issue update message only once Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode: Issue update message only once tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-02-09 13:30 +0100
[PATCH 11/17] x86/microcode/intel: Cleanup apply_microcode_intel() Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode/intel: Cleanup apply_microcode_intel() tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-02-09 13:30 +0100
[PATCH 14/17] x86/microcode/intel: Remove unused arg of get_matching_model_microcode() Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode/intel: Remove unused arg of get_matching_model_microcode() tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-02-09 13:30 +0100
[PATCH 08/17] x86/microcode/intel: Rename mc_saved_count to num_saved Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode/intel: Rename mc_saved_count to num_saved tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-02-09 13:30 +0100
[PATCH 04/17] x86/microcode: Remove an unneeded NULL check Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode: Remove an unneeded NULL check tip-bot for Dan Carpenter <tipbot@zytor.com> - 2016-02-09 13:30 +0100
[PATCH 03/17] x86/microcode: Remove redundant __setup() param parsing Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode: Remove redundant __setup() param parsing tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-02-09 13:30 +0100
[PATCH 17/17] x86/microcode: Document builtin microcode loading method Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode: Document builtin microcode loading method tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-02-09 13:30 +0100
[PATCH 16/17] x86/microcode/AMD: Issue microcode updated message later Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode/AMD: Issue microcode updated message later tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-02-09 13:30 +0100
[PATCH 09/17] x86/microcode/intel: Rename mc_intel variable to mc Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode/intel: Rename mc_intel variable to mc tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-02-09 13:30 +0100
[PATCH 06/17] x86/microcode/AMD: Drop redundant printk prefix Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode/AMD: Drop redundant printk prefix tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-02-09 13:30 +0100
[PATCH 13/17] x86/microcode/intel: Rename mc_saved_in_initrd Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode/intel: Rename mc_saved_in_initrd tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-02-09 13:30 +0100
[PATCH 01/17] x86/microcode: Untangle from BLK_DEV_INITRD Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode: Untangle from BLK_DEV_INITRD tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-02-09 13:30 +0100
[PATCH 15/17] x86/microcode/intel: Cleanup get_matching_model_microcode() Borislav Petkov <bp@alien8.de> - 2016-02-03 12:50 +0100
[tip:x86/microcode] x86/microcode/intel: Cleanup get_matching_model_microcode() tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-02-09 13:30 +0100
csiph-web