Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1330131

Re: [PATCH v2] x86/setup: Merge {early_,}reserve_initrd() to one function

From Alexander Kuleshov <kuleshovmail@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH v2] x86/setup: Merge {early_,}reserve_initrd() to one function
Date 2016-02-09 13:00 +0100
Message-ID <r0f7z-3uX-5@gated-at.bofh.it> (permalink)
References <qZYq8-qH-43@gated-at.bofh.it> <r0cCK-21t-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hello Ingo,

On Tue, Feb 9, 2016 at 3:16 PM, Ingo Molnar <mingo@kernel.org> wrote:
>
> So I don't think the code got easier to understand - in particular the
> memblock_reserve()/free() pattern, depending on a flag value, is confusing.
>
> The duplication is there - but please factor it out into a helper structure
> ('struct ramdisk') and a helper function that sets up the structure.

What if instead of `struct ramdisk`, we will move all definitions/check from
the early_reserve_initrd to the setup_arch() and than will pass these values
to the reserve_initrd()?

Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2] x86/setup: Merge {early_,}reserve_initrd() to one function Alexander Kuleshov <kuleshovmail@gmail.com> - 2016-02-08 19:10 +0100
  Re: [PATCH v2] x86/setup: Merge {early_,}reserve_initrd() to one  function Ingo Molnar <mingo@kernel.org> - 2016-02-09 10:20 +0100
    Re: [PATCH v2] x86/setup: Merge {early_,}reserve_initrd() to one function Alexander Kuleshov <kuleshovmail@gmail.com> - 2016-02-09 13:00 +0100
      Re: [PATCH v2] x86/setup: Merge {early_,}reserve_initrd() to one  function Ingo Molnar <mingo@kernel.org> - 2016-02-09 13:20 +0100

csiph-web