Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1331637
| From | Joe Perches <joe@perches.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/4] acct,time: change indentation in __acct_update_integrals |
| Date | 2016-02-11 02:30 +0100 |
| Message-ID | <r0Of0-1Jz-9@gated-at.bofh.it> (permalink) |
| References | <r0NVE-1Am-5@gated-at.bofh.it> <r0NVE-1Am-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Wed, 2016-02-10 at 20:08 -0500, riel@redhat.com wrote: > Change the indentation in __acct_update_integrals to make the function > a little easier to read. trivia: > diff --git a/kernel/tsacct.c b/kernel/tsacct.c [] > @@ -125,31 +125,32 @@ void xacct_add_tsk(struct taskstats *stats, struct task_struct *p) [] > + if (!likely(tsk->mm)) > + return; Using if (unlikely(!tsk->mm)) return; would be a lot more common. (~150:1 in the kernel sources)
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 2/4] acct,time: change indentation in __acct_update_integrals riel@redhat.com - 2016-02-11 02:10 +0100 Re: [PATCH 2/4] acct,time: change indentation in __acct_update_integrals Joe Perches <joe@perches.com> - 2016-02-11 02:30 +0100
csiph-web