Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1331416
| From | Dave Hansen <dave@sr71.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 0/3] [RFC] get_user_pages_remote(), now with creative macros |
| Date | 2016-02-10 19:20 +0100 |
| Message-ID | <r0HwR-5Rl-7@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
This is responding to some feedback from Ingo on the "get_user_pages_foreign()" patch: http://lkml.kernel.org/r/20160209124649.GA20153@gmail.com This new series breaks apart some of the changes in that original patch and adds some backward-compatibility to allow old-style get_user_pages() arguments to not break the build. The macros to do this are "fun". See patch #2. We also change the name to get_user_pages_remote(). This is a preparatory patch for the Memory Protection Keys work, but I am sending this separately for review to spare you from the ~30 other patches in the series that have not changed. cc: srikar dronamraju <srikar@linux.vnet.ibm.com> cc: vlastimil babka <vbabka@suse.cz> cc: andrew morton <akpm@linux-foundation.org> cc: kirill a. shutemov <kirill.shutemov@linux.intel.com> cc: andrea arcangeli <aarcange@redhat.com> cc: naoya horiguchi <n-horiguchi@ah.jp.nec.com> cc: jack@suse.cz
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 0/3] [RFC] get_user_pages_remote(), now with creative macros Dave Hansen <dave@sr71.net> - 2016-02-10 19:20 +0100 [PATCH 3/3] mm, gup: switch callers of get_user_pages() to not pass tsk/mm Dave Hansen <dave@sr71.net> - 2016-02-10 19:20 +0100 [PATCH 1/3] mm: introduce get_user_pages_remote() Dave Hansen <dave@sr71.net> - 2016-02-10 19:20 +0100 [PATCH 2/3] mm: overload get_user_pages() functions Dave Hansen <dave@sr71.net> - 2016-02-10 19:20 +0100
csiph-web