Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1329654

Re: [PATCH 1/2] devm: add helper devm_add_action_or_reset()

From Stephen Boyd <sboyd@codeaurora.org>
Newsgroups linux.kernel
Subject Re: [PATCH 1/2] devm: add helper devm_add_action_or_reset()
Date 2016-02-08 23:40 +0100
Message-ID <r02Dn-36m-7@gated-at.bofh.it> (permalink)
References <qIQIh-158-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 12/23, Sudip Mukherjee wrote:
> Add a helper function devm_add_action_or_reset() which will internally
> call devm_add_action(). But if devm_add_action() fails then it will
> execute the action mentioned and return the error code.
> 
> Signed-off-by: Sudip Mukherjee <sudip@vectorindia.org>
> ---

Greg, can I get your ack here to take this through clk-tree?

> 
> Next patch of the series will use this helper. And from a first glance
> more use of this helper will be there.
> 
>  include/linux/device.h | 12 ++++++++++++
>  1 file changed, 12 insertions(+)
> 
> diff --git a/include/linux/device.h b/include/linux/device.h
> index f627ba2..f2455d0 100644
> --- a/include/linux/device.h
> +++ b/include/linux/device.h
> @@ -682,6 +682,18 @@ void __iomem *devm_ioremap_resource(struct device *dev, struct resource *res);
>  int devm_add_action(struct device *dev, void (*action)(void *), void *data);
>  void devm_remove_action(struct device *dev, void (*action)(void *), void *data);
>  
> +static inline int devm_add_action_or_reset(struct device *dev,
> +					   void (*action)(void *), void *data)
> +{
> +	int ret;
> +
> +	ret = devm_add_action(dev, action, data);
> +	if (ret)
> +		action(data);
> +
> +	return ret;
> +}
> +
>  struct device_dma_parameters {
>  	/*
>  	 * a low level driver may set these to teach IOMMU code about

-- 
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum,
a Linux Foundation Collaborative Project

Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread


Thread

Re: [PATCH 1/2] devm: add helper devm_add_action_or_reset() Stephen Boyd <sboyd@codeaurora.org> - 2016-02-08 23:40 +0100
  Re: [PATCH 1/2] devm: add helper devm_add_action_or_reset() Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2016-02-09 00:20 +0100

csiph-web